开启左侧

精准抄底主图指标 源码 通达信

[复制链接]
本人测试了这个指标,很准现共享给大家

  1. DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'11',0);
  2. MA10:MA(C,10);
  3. MA60:MA(C,60);
  4. VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);
  5. VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);
  6. VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);
  7. VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));
  8. 加仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED;
  9. 减仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORGREEN;
  10. 洗盘:VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE;
  11. 高抛:VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORGREEN;
  12. 地量:VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORCYAN;
  13. DRAWKLINE(H,O,L,C);{好股票WWW.GOODGUPIAO.COM}
  14. TY:=C;
  15. A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
  16. A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
  17. 前期高位:REF(H,BARSLAST(HD)), COLORFF00FF,POINTDOT,LINETHICK3;
  18. 前期低位:REF(L,BARSLAST(LD)), COLORGREEN,POINTDOT,LINETHICK3;
  19. STICKLINE(洗盘,O,C,1,0),COLORWHITE;
  20. STICKLINE(减仓,O,C,1,0),COLORGREEN;
  21. STICKLINE(加仓,O,C,1,0),COLORRED;
  22. STICKLINE(地量,O,C,1,0),COLORCYAN;
  23. STICKLINE(高抛,O,C,1,0),COLORGREEN;
  24. JJ:=(3*C+H+L+O)/6;
  25. VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
  26. TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
  27. LJL:=FILTER(TJ1,5);
  28. STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),1,0),COLORCYAN;
  29. STICKLINE(CLOSE,REF(CLOSE,BARSLAST(LJL)),REF(CLOSE,BARSLAST(LJL)),1,0),COLORCYAN;
  30. STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW;
  31. DRAWTEXT_FIX(1,0.00,0.0,0,'白芯:主力轻度洗盘'),COLORWHITE,LINETHICK2;
  32. DRAWTEXT_FIX(1,0.0,0.06,0,'绿芯:主力重洗盘或高位卖出'),COLORGREEN,LINETHICK2;
  33. DRAWTEXT_FIX(1,0.00,0.12,0,'青芯:近期相对地量'),COLORCYAN,LINETHICK2;
  34. DRAWTEXT_FIX(1,0.00,0.18,0,'红芯:主力吸筹买入积极主动'),COLORRED,LINETHICK2;
  35. DRAWTEXT_FIX(1,0.00,0.24,0,'粉芯:主力高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK2;
  36. DRAWTEXT_FIX(1,0.00,0.3,0,'黄芯:主力进货强且成交量出现黄金柱'),COLORYELLOW,LINETHICK2;
  37. DRAWTEXT_FIX(C>0,0.10,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;
  38. DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;
  39. DRAWTEXT_FIX(C>0,0.12,1,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2;
  40. EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
  41. PL10:=ZIG(3,10);
  42. 走强2:=BARSLAST(PL10<REF(PL10,1));
  43. ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
  44. 追2:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
  45. 追4:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;
  46. DRAWTEXT(追2 OR 追4,LOW*0.95,'←追'),COLORYELLOW;
  47. PL5:=ZIG(3,5);
  48. EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
  49. EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
  50. EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
  51. PL20:=ZIG(3,20);
  52. EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
  53. EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
  54. PL40:=ZIG(3,40);
  55. 走强1:=BARSLAST(PL5<REF(PL5,1));
  56. 走弱1:=BARSLAST(PL5>REF(PL5,1));
  57. 走弱2:=BARSLAST(PL10>REF(PL10,1));
  58. 走强3:=BARSLAST(PL20<REF(PL20,1));
  59. 走弱3:=BARSLAST(PL20>REF(PL20,1));
  60. {ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);}
  61. ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
  62. DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
  63. DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
  64. ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
  65. ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
  66. DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
  67. DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
  68. DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'←反弹低点'),COLORCYAN;
  69. DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'←反弹高点'),COLORWHITE;
  70. DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'←底'),COLORYELLOW;
  71. DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'←减仓'),COLORWHITE;
  72. DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'←买'),COLORRED;
  73. DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'←短卖'),COLORGREEN;
  74. DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'←短买'),COLORRED;
  75. DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'←短卖'),COLORGREEN;
  76. DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'Ⅰ'),COLORYELLOW;
  77. DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'Ⅱ'),COLORYELLOW;
  78. DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'Ⅲ'),COLORYELLOW;
  79. DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLORYELLOW;
  80. DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.96,'②'),LINETHICK3,COLORYELLOW;
  81. DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.02,'←清仓'),LINETHICK3,COLORWHITE;
  82. DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.96,'④'),LINETHICK3,COLORYELLOW;
  83. DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.95,'⑷'),COLORYELLOW;
  84. EMA13:=EMA(C,13);
  85. EMA34:=EMA(C,34);
  86. EMA55:=EMA(C,55);
  87. EMA120:=EMA(C,120);
  88. CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
  89. CR2:=V>MA(V,5)*0.6;
  90. CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
  91. CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
  92. CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
  93. CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
  94. DRAWTEXT(CR6,C*0.98,'←风险'),COLORWHITE;

  95. LC:=REF(CLOSE,1);
  96. WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
  97. 获利筹码:=CONST(WINNER(C)*100);
  98. SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
  99. 量能饱和:=(IF(SAT>1,1,SAT)*100);
  100. WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
  101. 活跃:=(WRSI-WR10);
  102. 活跃度比:=IF(活跃>=0,(活跃+100)/2,100-ABS((活跃-100)/2));
  103. DRAWTEXT_FIX(1,0.23,1.15,1,STRCAT(STRCAT('量能饱和: ',CON2STR(量能饱和,2)),'%')),COLORYELLOW;
  104. DRAWTEXT_FIX(1,0.33,1.35,1,STRCAT(STRCAT('活跃度比: ',CON2STR(活跃度比,2)),'%')),COLORYELLOW;
  105. DRAWTEXT_FIX(1,0.43,1.55,1,STRCAT(STRCAT('获利筹码: ',CON2STR(获利筹码,2)),'%')),COLORYELLOW;

  106. 上涨家数:=STRCAT('沪深总上涨家数:',CON2STR(DYNAINFO(60),0));
  107. 下跌家数:=STRCAT('沪深总下跌家数:',CON2STR(DYNAINFO(61),0));
  108. DRAWTEXT_FIX(ISLASTBAR,0.46,5,0,上涨家数),COLORYELLOW;
  109. DRAWTEXT_FIX(ISLASTBAR,0.58,5,0,下跌家数),COLORYELLOW;
复制代码

精准抄底主图指标

精准抄底主图指标

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1