开启左侧

金色狂牛副图指标 源码 通达信

[复制链接]
  1.   VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
  2.   VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  3.   VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  4.   VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  5.   VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  6.   VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  7.   VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  8.   VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  9.   VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  10.   VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  11.   VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  12.   VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  13.   VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
  14.   VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  15.   VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  16.   VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  17.   VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  18.   VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  19.   VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  20.   VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  21.   VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  22.   VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  23.   VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  24.   VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  25.   VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
  26.   VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
  27.   TYP := (HIGH + LOW + CLOSE)/3;
  28.   CC1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORFF00FF;
  29.   C1:=SMA(CC1,3,1);
  30.   C2:=SMA(C1,3,1);
  31.   C3:=3*C1-2*C2;
  32.   CB1:=EMA(C3,5);
  33.   CB2:=REF(CB1,1);
  34.   LC := REF(CLOSE,1);
  35.   RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
  36.   RSI:=(RSI1-50)*5,LINETHICK2,COLORFFFFFF;
  37.   R1:=SMA(RSI,3,1);
  38.   D1:=SMA(R1,3,1);
  39.   J1:=3*R1-2*D1;
  40.   RR1:=EMA(J1,5);
  41.   RR2:=REF(RR1,1);
  42.   RR:=RR1>RR2;
  43.   RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  44.   K:=SMA(RSV,3,1);
  45.   K1:=(K-50)*5,COLOR00FF00;
  46.   K2:=SMA(K1,3,1);
  47.   D2:=SMA(K2,3,1);
  48.   J2:=3*K2-2*D2;
  49.   BB1:=EMA(J2,5);
  50.   金牛出现: RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100 AND VAR19=1,COLORFF0080;
  51.   STICKLINE(金牛出现,80,1,2,0),COLOR800040;
  52.   STICKLINE(金牛出现,80,1,1.5,0),COLORFF0080;
  53.   STICKLINE(金牛出现,80,1,1,0),COLOR800080;
  54.   STICKLINE(金牛出现,80,1,0.3,0),COLORFF00FF;
  55.   DRAWTEXT(金牛出现,50,' 金牛出现'),COLORFF0080;
  56.   DRAWICON(金牛出现>0,83,9);
复制代码

金色狂牛副图指标

金色狂牛副图指标

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝0

帖子198

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1