开启左侧

天地双龙操盘主图指标 源码 通达信 无未来函数

[复制链接]
  1. M:=13;
  2. VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
  3. VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  4. VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  5. VARW1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
  6. VARW2:=REF(VARW1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  7. VARW3:=REF(VARW2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  8. VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  9. VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  10. VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  11. VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  12. VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  13. VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  14. VARW4:=REF(VARW3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  15. VARW5:=REF(VARW4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  16. VARW6:=REF(VARW5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  17. VARW7:=REF(VARW6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  18. VARW8:=REF(VARW7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  19. VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  20. VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  21. VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  22. VARW9:=REF(VARW8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  23. VARWA:=REF(VARW9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  24. VARWB:=REF(VARWA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  25. VARWC:=REF(VARWB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  26. STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8
  27. OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,0),COLORRED;
  28. STICKLINE(VARW1 OR VARW2 OR VARW3 OR VARW4 OR VARW5 OR VARW6 OR VARW7 OR
  29. VARW8 OR VARW9 OR VARWA OR VARWB OR VARWC,CLOSE,REF(CLOSE,1),3,1),COLORRED;
  30. VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
  31. VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  32. VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  33. VARWD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
  34. VARWE:=REF(VARWD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  35. VARWF:=REF(VARWE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  36. VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  37. VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  38. VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  39. VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  40. VARW10:=REF(VARWF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  41. VARW11:=REF(VARW10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  42. VARW12:=REF(VARW11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  43. VARW13:=REF(VARW12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  44. VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  45. VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  46. VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  47. VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  48. VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  49. VARW14:=REF(VARW13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  50. VARW15:=REF(VARW14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  51. VARW16:=REF(VARW15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  52. VARW17:=REF(VARW16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
  53. VARW18:=REF(VARW17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
  54. STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
  55. VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORYELLOW;
  56. VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13
  57. OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
  58. STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA;
  59. VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR
  60. VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
  61. STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR008800;
  62. STICKLINE(VARWD OR VARWE OR VARWF OR VARW10 OR VARW11 OR VARW12 OR VARW13 OR
  63. VARW14 OR VARW15 OR VARW16 OR VARW17 OR VARW18,CLOSE,REF(CLOSE,1),3,0),COLORFFCC66;
  64. RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
  65. K:=SMA(RSV,3,1);
  66. D:=SMA(K,3,1);
  67. J:=3*K-2*D;
  68. VARW1A:=REF(VARW1 OR VARW2 OR VARW3 OR VARW4 OR VARW5 OR VARW6 OR VARW7 OR
  69. VARW8 OR VARW9 OR VARWA OR VARWB OR VARWC,1) AND VARWD;
  70. RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
  71. K24:=SMA(RSV24,3,1);
  72. D24:=SMA(K24,3,1);
  73. J24:=3*K24-2*D24;
  74. STICKLINE(VARW1A,REF(CLOSE,1),REF(CLOSE,2),5,2),COLOR00FF00;
  75. STICKLINE(VARW1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;
  76. STICKLINE(VARW1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORBLUE;
  77. STICKLINE(VARW1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;
  78. 压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR00FF33,LINETHICK1;
  79. 支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK1;
  80. 支撑价:LLV(LOW,34) ,COLOR7FFF00,COLORWHITE;
  81. 阻力价:HHV(HIGH,34),COLORFF9900,COLORLIBLUE,LINETHICK1;
  82. PMA:MA(C,5),COLORWHITE,LINETHICK2;
  83. IF(PMA>REF(PMA,1),PMA,DRAWNULL),COLORRED,LINETHICK2;
  84. IF(PMA<REF(PMA,1),PMA,DRAWNULL),COLORGREEN,LINETHICK2;
  85. DRAWTEXT(C-O>=0 AND O/L>1.05 AND L<=LLV(L,30),L,'极品绝底'), LINETHICK1;
  86. X:=(3*C+L+O+H)/6;
  87. 多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,
  88. 5)+14*REF(X,6)+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,
  89. 11)+8*REF(X,12)+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,
  90. 17)+2*REF(X,18)+REF(X,20))/210,COLORFF00FF,LINETHICK2;
  91. DD:=多空线<REF(多空线,1);
  92. A:=(PMA>多空线);
  93. IF(A,多空线,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;
  94. WWWGOODGUPIAOCOM:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
  95. VARW21:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
  96. 3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
  97. VARW22:=8;
  98. WW:=CROSS(VARW21,VARW22);
  99. DRAWTEXT(WW,L*0.98,'买进!'),COLOR0099FF;

复制代码

天地双龙操盘主图指标 源码 通达信

天地双龙操盘主图指标 源码 通达信

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1