开启左侧

通达信手机版 KD钝化指标源码

[复制链接]
本帖最后由 ynjie 于 2020-2-13 12:39 编辑

通达信手机版 KD钝化指标源码
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,100,100,100,0),COLORGREEN;STICKLINE(1,20,20,100,0),COLORLIGRAY;
  3. STICKLINE(1,50,50,100,0),COLORCYAN;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  6. K:SMA(RSV,3,1);
  7. D:SMA(K,3,1);
  8. J:=3*K-2*D,NODRAW;
  9. DRAWBAND(K,RGB(255,0,0),D,RGB(0,255,0));
  10. DRAWICON(CROSS(K,D),K,1);
  11. DRAWICON(CROSS(D,K),D,2);
  12. 判:REF((D*3-K*2)*(HHV(H,(9-1))-LLV(L,(9-1)))/100+LLV(L,(9-1)),1)NODRAW;
  13. 预2:REF(LLV(L,(9-1))+(HHV(H,(9-1))-LLV(L,(9-1)))*(3*20-(3-1)*K)/100,1),NODRAW;
  14. 预5:REF(LLV(L,(9-1))+(HHV(H,(9-1))-LLV(L,(9-1)))*(3*50-(3-1)*K)/100,1),COLORWHITE,NODRAW;
  15. 预8:REF(LLV(L,(9-1))+(HHV(H,(9-1))-LLV(L,(9-1)))*(3*80-(3-1)*K)/100,1),NODRAW;
  16. JC:="KD.D">"KD.K";
  17. SC:="KD.K">"KD.D";
  18. 金:INTPART(BARSLAST(JC)),NODRAW;
  19. 死:INTPART(BARSLAST(SC)),NODRAW;
  20. DRAWICON(COUNT(K>80,1)=1,90,41);
  21. DRAWICON(COUNT(K>80,3)=3,90,36);
  22. DRAWICON(COUNT(K<20,1)=1,10,41);
  23. DRAWICON(COUNT(K<20,3)=3,10,37);
复制代码



1.jpg


回复
0

使用道具 举报

懒得打字嘛,点击快捷回复 【回复乱码 永久禁言】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝2

帖子1104

发布主题
推荐素材更多+
广告位


QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1