开启左侧

缠论主图指标 通达信 源码 自动画线

  [复制链接]
本帖最后由 Money 于 2020-10-7 14:33 编辑

缠论主图指标 通达信

缠论主图指标 通达信
缠论主图指标 通达信 源码

缠论主图指标 通达信 源码 自动画线

缠论主图指标 通达信 源码 自动画线
缠论主图指标 通达信 源码

缠论主图指标 通达信

缠论主图指标 通达信

缠论主图指标 通达信
  1. {缠论}
  2. TIM:=TDXDLL3(100,PERIOD,H,L);    {初始化周期};
  3. KX:=TDXDLL3(1,H,L,C);      {解决包含K线的问题};
  4. VALID:=TDXDLL3(15,H,L,C);
  5. BI:=TDXDLL3(4,H,L,C);     {BI类型}
  6. KXG:=TDXDLL3(2,H,L,C); {高点}
  7. KXD:=TDXDLL3(3,H,L,C); {低点}
  8. BILAST:=TDXDLL3(6,H,L,C);{上一笔的距离}
  9. {画笔}
  10. DRAWLINE(BI=1, KXG, BI=-1, KXD,0),COLORYELLOW;
  11. DRAWLINE(BI=-1, KXD, BI=1, KXG,0),COLORYELLOW;
  12. BILIST:=TDXDLL3(5,H,L,C);{BILIST}
  13. DUANLAST:=TDXDLL3(7,H,L,C);{上一段的距离}
  14. ZS:=TDXDLL3(8,H,L,C);{中枢处理}
  15. ZSZG:=TDXDLL3(9,H,L,C);{得到中枢ZG}
  16. ZSZD:=TDXDLL3(10,H,L,C);{得到中枢ZD}
  17. ZSKS:=TDXDLL3(11,H,L,C);{得到中枢开始}
  18. ZSJS:=TDXDLL3(12,H,L,C);{得到中枢结束}
  19. BIFX:=-REF(BI,BILAST);
  20. {下跌笔中枢}
  21. DRAWLINE(ZSKS=1,ZSZG,ZSJS=1,ZSZG,0),COLOR1D7300,LINETHICK2;
  22. DRAWLINE(ZSKS=1,ZSZD,ZSJS=1,ZSZD,0),COLOR1D7300,LINETHICK2;
  23. DRAWLINE(ZSKS=1,(ZSZG+ZSZD)/2,ZSJS=1,(ZSZG+ZSZD)/2,0),COLOR1D7300,DOTLINE;
  24. STICKLINE(ZSKS=1,ZSZG,ZSZD,0.1,0),COLOR1D7300;
  25. STICKLINE(ZSJS=1,ZSZG,ZSZD,0.1,0),COLOR1D7300;
  26. {上涨笔中枢}
  27. DRAWLINE(ZSKS=2,ZSZG, ZSJS=2,ZSZG,0),COLORRED,LINETHICK2;
  28. DRAWLINE(ZSKS=2,ZSZD, ZSJS=2,ZSZD,0),COLORRED,LINETHICK2;
  29. DRAWLINE(ZSKS=2,(ZSZG+ZSZD)/2,ZSJS=2,(ZSZG+ZSZD)/2,0),COLORRED,DOTLINE;
  30. STICKLINE(ZSKS=2,ZSZG,ZSZD,0.1,0),COLORRED;
  31. STICKLINE(ZSJS=2,ZSZG,ZSZD,0.1,0),COLORRED;
  32. {绘制最后当下的力度}
  33. DRAWNUMBER(BI=1 AND N1=0,H,H-REF(L,BILAST)),COLORMAGENTA;
  34. DRAWNUMBER(BI=-1 AND N1=0,L,L-REF(H,BILAST)),COLORCYAN;

  35. {平滑移动平均}
  36. MA26:=EMA(C,26);
  37. MA13:=EMA(C,13);

  38. VAR1:=KX;
  39. VAR2:=BI;
  40. 分型:=VAR1;
  41. 笔:=VAR2;
  42. A1:=BARSLAST(VAR2<>0);{上个顶底到现在的时间}
  43. A2:=REF(VAR2,A1); {是顶还是底}
  44. AA1:=REF(A1+1,1); {上个顶底到现在的时间}
  45. AA2:=-REF(A2,1); {1 上涨, -1下跌}
  46. 方向:=AA2;
  47. AA3:=AA1+REF(AA1+1,AA1);
  48. AA4:=AA3+REF(AA1+1,AA3);
  49. H1:=BARSLAST(VAR2=1);
  50. H2:=REF(VAR2,H1);
  51. HH1:=REF(H1+1,1); HH2:=-REF(H2,1);
  52. L1:=BARSLAST(VAR2=-1);
  53. L2:=REF(VAR2,L1);
  54. LL1:=REF(L1+1,1); LL2:=-REF(L2,1);
  55. {高低点}
  56. GG:=REF(H,H1);
  57. GG1:=REF(H,HH1);
  58. GG2:=REF(GG1,HH1);
  59. GG3:=REF(GG2,HH1);
  60. GG4:=REF(GG3,HH1);
  61. GG5:=REF(GG4,HH1);
  62. DD:=REF(L,L1);
  63. DD1:=REF(L,LL1);
  64. DD2:=REF(DD1,LL1);
  65. DD3:=REF(DD2,LL1);
  66. DD4:=REF(DD3,LL1);
  67. DD5:=REF(DD4,LL1);
  68. {买点}
  69. {主要是从形态考虑TJA, 空间做为次要条件KJ提高成功率 }

  70. {一买}
  71. {反弹高点站不上26天线就}
  72. {利用形态抓下+盘+下}
  73. 一买TJ1:=方向=1 AND L<MA13 AND LL1<=5;
  74. 一五段下跌:=DD1<GG1 AND DD1<DD2 AND DD1<DD3 AND GG1<GG2 AND GG1<GG3;
  75. 一买TJA:=GG1<DD3; {存在缺口}
  76. 一买A:=一买TJ1 AND 一五段下跌 AND 一买TJA, LINETHICK0, COLORRED; {89%}
  77. 一买KJA:=GG1-DD1<GG2-DD2 AND GG1-DD1>GG3-DD3 AND GG3-DD3<GG2-DD2 AND GG2-DD2>(GG1-DD1)*1.618;
  78. 一买AAA:=一买TJ1 AND 一五段下跌 AND 一买TJA AND 一买KJA, LINETHICK0, COLORRED; {93%}
  79. 一买TJB:=GG1>DD3; {不存在缺口}
  80. 一买KJB:=GG3-DD3>GG1-DD1 AND GG3-DD3>GG2-DD2 AND GG2-DD2<GG1-DD1;
  81. 一买B:=一买TJ1 AND 一五段下跌 AND 一买TJB AND 一买KJB, LINETHICK0, COLORRED; {85}
  82. {类二买}
  83. {思路是 利用形态抓上+盘+(上)}{注意有这两个条件成功率提高很多 GG1>GG2 AND DD1>DD2}
  84. 类二买TJ:=方向=1 AND C<MA13 AND LL1<=8;
  85. 类二买TJ2:=DD1<GG1 AND DD3<DD2 AND DD3<DD1 AND DD3<DD4;
  86. 类二买KJ:=GG2-DD3>GG2-DD2 AND GG2-DD3>GG1-DD1;
  87. 类二买A:=类二买TJ AND 类二买TJ2 AND类二买KJ,COLORRED; {85}
  88. 类二买TJA:=GG1>GG2 AND DD1>DD2 AND GG2-DD3>(GG2-DD2)*1.618;{力度大概影响3个点左右}
  89. 类二买AAA:=类二买A AND 类二买TJA,COLORRED; {最强买} {90}
  90. {二买1:OK:PASS}

  91. {二买}
  92. 买TJ1:=方向=1 AND L<MA26 AND LL1<=8;
  93. 二买TJ:=DD1<GG1 AND DD1>DD2; {二买形态}
  94. 三段下跌:=GG3>GG2 AND DD3>DD2; {三段式下跌}
  95. 二买TJA1:=GG1>DD3; {第一段上涨至少回到前中枢内}
  96. 二买A:=买TJ1 AND 二买TJ AND 三段下跌 AND 二买TJA1, LINETHICK0, COLORYELLOW; {77.5}
  97. 五段下跌:=GG4>GG3 AND GG4>GG2 AND DD2<DD3 AND DD2<DD4; {五段下跌}
  98. 二买TJB1:=GG2<DD4 AND GG1>DD3; {存在缺口}
  99. 二买TJB2:=GG2>DD4; {不存在缺口}
  100. 二买B1:=买TJ1 AND 二买TJ AND 五段下跌 AND 二买TJB1, LINETHICK0, COLORYELLOW;{91.7 - 3}
  101. 二买B2:=买TJ1 AND 二买TJ AND 五段下跌 AND 二买TJB2, LINETHICK0, COLORYELLOW;{75.8}
  102. 二买AAA:=二买B1, LINETHICK0, COLORYELLOW;

  103. {三买}
  104. 三买TJ:=DD1<GG1 AND DD1>DD2;
  105. 三买TJA1:=方向=1 AND L<MA13 AND LL1<=5;
  106. 三买TJA2:=DD1>MIN(GG2,GG3) AND GG3>DD2 AND DD4<MAX(DD2,DD3) AND DD1>DD4 ; {GG2 GG3 在同一中枢内}
  107. 三买A:=三买TJ AND 三买TJA1 AND 三买TJA2,COLORMAGENTA; {如果DD1>GG4成功率更高}

  108. {卖点}{主要是从形态考虑 买点 的逆向思维 不考虑空间}
  109. {一卖}
  110. 一卖TJ1:=方向=-1 AND H>MA13 AND HH1<=5;
  111. 一五段上涨:=GG1>GG2 AND GG1>GG3 AND DD1>DD2 AND DD1>DD3;
  112. 一卖TJA:=DD1>GG3; {缺口}
  113. 一卖A:=一卖TJ1 AND 一五段上涨 AND 一卖TJA,COLORGREEN;
  114. 一卖TJB:=DD1<GG3 AND GG1-DD1>GG2-DD2 AND GG3-DD3-GG2-DD2;
  115. 一卖B:=一卖TJ1 AND 一五段上涨 AND 一卖TJB,COLORGREEN;
  116. 一卖TJC:=GG1>GG2 AND GG2>GG3 AND GG3>GG4 AND GG4>GG5 AND DD1>DD2 AND DD2>DD3 AND DD3>DD4 AND DD4>DD5; {连涨4段}
  117. 一卖C:=一卖TJ1 AND 一卖TJC,COLORGREEN; {27 - 68}

  118. {二卖}
  119. 卖TJ1:=方向=-1 AND H>MA13 AND HH1<=8;
  120. 二卖TJ:=GG1>DD1 AND GG1<GG2; {二卖形态}
  121. 三段上涨:=GG3<GG2 AND DD3<DD2; {三段式上涨}
  122. 二卖TJA1:=DD1>GG3; {第一段下跌至少回到前中枢内}
  123. 二卖A:=卖TJ1 AND 二卖TJ AND 三段上涨 AND 二卖TJA1, LINETHICK0, COLORF0F000; {44-50}
  124. 五段上涨:=GG2>GG3 AND GG2>GG4 AND DD4<DD3 AND DD4<DD2; {五段上涨}
  125. 二卖TJB1:=GG4<DD2 AND DD1<GG3; {存在缺口}
  126. 二卖TJB2:=GG4>DD2; {不存在缺口}
  127. 二卖B1:=卖TJ1 AND 二卖TJ AND 五段上涨 AND 二卖TJB1, LINETHICK0, COLORF0F000;{38 - 48}
  128. 二卖B2:=卖TJ1 AND 二卖TJ AND 五段上涨 AND 二卖TJB2, LINETHICK0, COLORF0F000;{39 - 48}
  129. 一段上涨:=GG2>GG3 AND GG2>GG4 AND DD1>MIN(GG3, GG4); {在下跌时有点三卖的感觉}
  130. 二卖C1:=卖TJ1 AND 二卖TJ AND 一段上涨, LINETHICK0, COLORF0F000; {41 47}

  131. {三卖}
  132. 三卖TJ:=DD1<GG1 AND GG1<GG2;
  133. 三卖TJA1:=方向=-1 AND H>MA13 AND HH1<=5;
  134. 三卖TJA2:=GG1<MAX(DD2,DD3) AND GG2>DD3 AND GG4>MIN(GG2,GG3) AND GG1<GG4 ; {GG2 GG3 在同一中枢内}
  135. 三卖A:=三卖TJ AND 三卖TJA1 AND 三卖TJA2 , LINETHICK0, COLORWHITE; {GG1<DD4成功率更高}

  136. {买卖点提示}
  137. 一买:=一买A OR 一买B, COLORRED;
  138. 类二买:=类二买A, COLORRED;
  139. 二买:=二买A OR 二买B1 OR 二买B2, COLORYELLOW;
  140. 三买:=三买A, COLORMAGENTA;

  141. 一卖:=一卖A OR 一卖B OR 一卖C, COLORGREEN;
  142. 二卖:=二卖A OR 二卖B1 OR 二卖B2 OR 二卖C1, COLORF0F000;
  143. 三卖:=三卖A, COLORWHITE;

  144. 二三买合:=二买 AND 三买,COLORMAGENTA; {85 信号量少}
  145. 二三卖合:=二卖 AND 三卖, COLORF0F000; {13-87}

  146. 高成功率:=一买AAA OR 二买AAA OR 类二买AAA;
  147. 次高成功:=二三买合;
  148. 清仓:=二三卖合;
  149. DRAWTEXT(一买 AND FILTER(一买, 8),  REF(L,1), '↑①'),COLORYELLOW;
  150. DRAWTEXT(类二买 AND FILTER(类二买, 8) , REF(L,1), '↑类②'),COLORYELLOW;
  151. DRAWTEXT(二买 AND FILTER(二买, 8), REF(L,1), '↑②'), COLORYELLOW;
  152. DRAWTEXT(三买 AND FILTER(三买, 8), REF(L,1), '↑③'),COLORYELLOW;
  153. DRAWTEXT(一卖 AND FILTER(一卖, 8),  REF(H,1), '↓①'), COLORGREEN ;
  154. DRAWTEXT(二卖 AND FILTER(二卖, 8) , REF(H,1), '↓②'), COLORGREEN;
  155. DRAWTEXT(三卖 AND FILTER(三卖, 8) ,  REF(H,1), '↓③'), COLORGREEN;
  156. {涨停板}
  157.   TB:=(C-REF(C,1))/REF(C,1)*100;
  158.   STICKLINE(TB>9.9,O,C,2.5,1)COLORMAGENTA;
  159.   STICKLINE(TB<-9.9,O,C,2.5,0)COLOR1D7300;
复制代码
缠论主图指标 通达信
游客,如果您要查看本帖隐藏内容请回复



回复

使用道具 举报

精彩评论73

sunqingxia2010 发表于 2020-10-7 20:16:55 | 显示全部楼层
非常感谢分享!
回复

使用道具 举报

yzw2834859 发表于 2020-10-10 11:54:04 | 显示全部楼层
非常感谢分享!
回复

使用道具 举报

cos136 发表于 2020-10-17 14:18:40 | 显示全部楼层
:(:):)好好好
回复

使用道具 举报

sxymyg 发表于 2020-11-1 00:46:18 | 显示全部楼层
这个非得产生的高温较好的混的
回复

使用道具 举报

jinxiaoshao 发表于 2020-11-6 15:31:44 | 显示全部楼层
楼主发贴辛苦了,谢谢楼主分享!我觉得与你共享www.ynjie.com是注册对了!
回复

使用道具 举报

yzxu79 发表于 2020-11-23 14:04:25 | 显示全部楼层
非常感谢楼主的无私奉献
回复

使用道具 举报

biji202010 发表于 2020-11-25 15:21:27 | 显示全部楼层
谢谢楼主分享和奉献。。。
回复

使用道具 举报

oooodo 发表于 2020-11-25 22:13:48 | 显示全部楼层
8q73ef8q73ef8q73ef8q73ef
回复

使用道具 举报

oooodo 发表于 2020-11-25 22:16:06 | 显示全部楼层
偷盗偷盗偷盗偷盗偷盗
回复

使用道具 举报

懒得打字嘛,点击快捷回复 【回复乱码 永久禁言】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝39

帖子5048

发布主题
推荐素材更多+
广告位

服务电话

15987183307

QQ:1136111231
关注我们 :

QQ- Archiver-手机版-小黑屋-经典-文库- 与你共享

Powered by ynjie.com Array© 2001-2013 ynjie.com  滇ICP备19007624号-1