开启左侧

全景看盘主图指标 源码 飞狐

[复制链接]
本帖最后由 Money 于 2020-5-4 23:43 编辑

主图源码添加后,请再导入引用指标。
飞狐软件---点击管理---扩展数据管理---按指标排序依次排列。
游客,如果您要查看本帖隐藏内容请回复

  1. <font size="3">N    缺省 4    最小 1  最大 100
  2. N1   缺省 10   最小 1  最大 100
  3. N3   缺省 9    最小 1  最大 100
  4. Q    缺省 7    最小 1  最大 100
  5. Q1   缺省 27    最小 1  最大 100
  6. P2   缺省 3    最小 1  最大 100
  7. P1   缺省 3    最小 1  最大 100

  8. {半分位}
  9. STICKLINE(CLOSE>0,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,8,101),colorWhite,LINETHICK3;
  10. STICKLINE(LOW<>MIN(CLOSE,OPEN),(LOW+MIN(CLOSE,OPEN))/2,(LOW+MIN(CLOSE,OPEN))/2,4,1),COLORYELLOW,LINETHICK1;
  11. STICKLINE(HIGH<>MAX(CLOSE,OPEN),(HIGH+MAX(CLOSE,OPEN))/2,(HIGH+MAX(CLOSE,OPEN))/2,4,1),COLORYELLOW,LINETHICK1;
  12. {均线}
  13. wx:=MA(CLOSE,0);
  14. M5:MA(CLOSE,5),COLORYELLOW;
  15. M10:MA(CLOSE,10)*IF(n<2,wx,1),COLORMAGENTA;
  16. M20:MA(CLOSE,20)*IF(n<3,wx,1),COLORWHITE;
  17. {M30:=MA(CLOSE,30)*IF(n<4,wx,1);
  18. M60:=MA(CLOSE,60)*IF(n<4,wx,1);
  19. M90:=MA(CLOSE,90)*IF(n<4,wx,1);}
  20. {布林轨道}
  21. {市值定价}
  22. 市盈率:=IF(FINANCE(33)>0,DYNAINFO(39),0)*0.35;
  23. 每股收益:=IF(FINANCE(33)>0.01,FINANCE(33)*0.65,0);
  24. 市值定价:=每股收益*市盈率*4;
  25. DRAWTEXTEX(CLOSE,1,485,10,'【市值定价】'+NUMTOSTR(市值定价,2)+' 元'),COLORYELLOW;
  26. {饱和量能}
  27. SAT:=IF((AMOUNT/CLOSE)/(HHV(AMOUNT,21)/HHV(CLOSE,21))*100>100,100,(AMOUNT/CLOSE)/(HHV(AMOUNT,21)/HHV(CLOSE,21))*100);

  28. p:=SYSPARAM(1);
  29. DRAWTEXTEX(CLOSE,1,485,70,'【饱和量能】'+NUMTOSTR(SAT,2)+' %'),COLORYELLOW;

  30. {主力筹码}
  31. 主力筹码:=10*WINNER(CLOSE*0.9)*8;
  32. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,40,'【主力筹码】'+NUMTOSTR(主力筹码[SYSPARAM(1)],2)+' %'),COLORYELLOW,PXUP0;
  33. ZHH:=HIGH;ZGF1:= ZHH/1.0809;  ZGF2:=ZHH/1.1618;   ZGF3:=ZHH/1.0809/1.1618; ZGF4:=ZHH/1.1618/1.1618;
  34. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,70,'■第一下跌区位:'+NUMTOSTR(ZGF1[SYSPARAM(1)],2)+'-'+NUMTOSTR(ZGF2[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
  35. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,100,'■第二下跌区位:'+NUMTOSTR(ZGF3[SYSPARAM(1)],2)+'-'+NUMTOSTR(ZGF4[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
  36. ZLL:=LOW;ZGFB1:=ZLL*1.0809;    ZGFB2:=ZLL*1.1618;   ZGFB3:=ZLL*1.0809*1.1618;  ZGFB4:=ZLL*1.1618*1.1618;
  37. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,40,'■第一上涨区位:'+NUMTOSTR(ZGFB1[SYSPARAM(1)],2)+''+'-'+NUMTOSTR(ZGFB2[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
  38. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,10,'■第二上涨区位:'+NUMTOSTR(ZGFB3[SYSPARAM(1)],2)+''+'-'+NUMTOSTR(ZGFB4[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
  39. PT:=REF(HIGH,1)-REF(LOW,1);
  40. CDP:=(HIGH+LOW+2*CLOSE)/4;
  41. AH:=CDP+PT;
  42. AL:=CDP-PT;
  43. NH敏感阻力:=2*CDP-LOW;
  44. NL:=2*CDP-HIGH;
  45. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,130,'■明日强阻力位:'+NUMTOSTR(AH[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
  46. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,160,'■明日阻力区域:'+NUMTOSTR(NH敏感阻力[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
  47. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,190,'■明日均衡价位:'+NUMTOSTR(CDP[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
  48. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,220,'■明日支撑区域:'+NUMTOSTR(NL[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
  49. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,250,'■明日强支撑位:'+NUMTOSTR(AL[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
  50. 主力持仓:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
  51. 主力筹码集中度:=WINNER(CLOSE)*100;
  52. 散筹筹码集中度:=(WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*100;
  53. qiang:=(主力持仓-散筹筹码集中度)>20 and (主力筹码集中度-散筹筹码集中度)>0 and 主力持仓>50;
  54. 庄家显身:=IF(qiang,1,0);
  55. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,460,'■庄家显身:'+NUMTOSTR(庄家显身[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
  56. 庄家控局:=IF(qiang and 主力筹码集中度-散筹筹码集中度>20,1,0);
  57. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,490,'■庄家控局:'+NUMTOSTR(庄家控局[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
  58. A2:=SUM(VOL,13)/CAPITAL;
  59. 强弱分界:=100-(100/(1+A2));
  60. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,400,'■弱势指数:'+NUMTOSTR(强弱分界[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
  61. A3:=LLV(DMA(CLOSE,VOL/CAPITAL),120);
  62. 股价走势:=100*(CLOSE-A3)/A3;
  63. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,430,'■强势指数:'+NUMTOSTR(股价走势[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
  64. {D J 系数}
  65. RSV:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
  66. K:=SMA(RSV,P1,1);
  67. D:=SMA(K,P2,1);
  68. 起涨系数:=3*K-2*D;
  69. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,130,'【D J 系数】↓'+NUMTOSTR(起涨系数[SYSPARAM(1)],2)+' %'),COLORYELLOW,PXUP0;

  70. {资金进出}
  71. V1:=(CLOSE*2+HIGH+LOW)/4*10;
  72. V2:=EMA(V1,13)-EMA(V1,34);
  73. V3:=EMA(V2,5); V4:=2*(V2-V3)*5.5;
  74. 主力进:=IF(V4>=0,V4,0);  
  75. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,340,'■主力进场强度:'+NUMTOSTR(主力进[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
  76. 主力撤:=IF(V4<=0,V4,0);
  77. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,370,'■主力出场强度:'+NUMTOSTR(主力撤[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
  78. V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
  79. V6:=EMA(3*V5-2*SMA(V5,18,1),5);
  80. V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
  81. V8:=(INDEXC*2+INDEXH+INDEXL)/4;
  82. V9:=EMA(V8,13)-EMA(V8,34);
  83. VA:=EMA(V9,3);
  84. VB:=(V9-VA)/2;
  85. 资金进场:=IF(VB>=0,VB,0);
  86. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,280,'■资金进场强度:'+NUMTOSTR(资金进场[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
  87. 资金出场:=IF(VB<=0,VB,0);
  88. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,310,'■资金出场强度:'+NUMTOSTR(资金出场[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
  89. {建仓}
  90. Q4:=34;
  91. Q5:=9;
  92. Q6:=3;
  93. X1:=100*(HHV(HIGH,Q4)-CLOSE)/(HHV(HIGH,Q4)-LLV(LOW,Q4));
  94. VAR1:=100*(HHV(HIGH,Q5)-CLOSE)/(HHV(HIGH,Q5)-LLV(LOW,Q5));
  95. VAR2:=100*(HHV(HIGH,Q6)-CLOSE)/(HHV(HIGH,Q6)-LLV(LOW,Q6));
  96. VAR3:=VAR1-X1;
  97. VAR4:=X1-VAR1;
  98. 游资建仓:=VAR3<0;
  99. 机构对倒:=VAR4<0;
  100. VAR5:=DYNAINFO(5);
  101. VAR6:=IF(HIGH<VAR5,0,IF(LOW>VAR5,1,(VAR5-HIGH+0.009)/(LOW-HIGH+0.009)));
  102. AAA:=CLOSE*1.1;
  103. BBB:=CLOSE*0.9;
  104. BB1:=100*(WINNER(AAA)-WINNER(BBB));
  105. CMSD:=100-BB1;
  106. CC1:=MA(CLOSE,13)<REF(MA(CLOSE,13),1);
  107. DD1:=IF(CLOSE>1000,CROSS(VAR6,22),CROSS(VAR6,24));
  108. 机构建仓:=CMSD>65 AND CC1;
  109. ZC_1:=IF(LOW<DYNAINFO(7),0,IF(HIGH>DYNAINFO(7),DYNAINFO(7)-(DYNAINFO(7)-HIGH+0.02)/(HIGH-LOW+0.02),0));
  110. ZC_2:=DMA(ZC_1,VOL/CAPITAL)*(100);
  111. 出货:=IF(ZC_2>0 AND ZC_2>REF(ZC_2,1),ZC_2/20,0);
  112. 机构出货:=出货>0;
  113. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,520,'■机构参与:'+NUMTOSTR(机构建仓[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
  114. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,610,'■机构出货:'+NUMTOSTR(机构出货[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
  115. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,580,'■机构对倒:'+NUMTOSTR(机构对倒[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
  116. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,550,'■游资参与:'+NUMTOSTR(游资建仓[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
  117. {权证}
  118. Var1:=IF(DATE<1090801 AND DATE>900101,1,0);
  119. VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
  120. VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  121. VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  122. VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  123. VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  124. VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  125. VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  126. VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  127. VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  128. VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  129. VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  130. VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  131. STICKLINE((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),CLOSE,REF(CLOSE,1),8,1),colorFF;
  132. VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
  133. VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  134. VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  135. VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  136. VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  137. VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  138. VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  139. VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  140. VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  141. VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  142. VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  143. VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  144. STICKLINE((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),CLOSE,REF(CLOSE,1),8,1),COLORGREEN;
  145. VAR1A:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
  146. STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),8,0)COLORYELLOW;
  147. AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
  148. STICKLINE(AA,REF(CLOSE,1),REF(CLOSE,2),10,0)COLORBLUE;
  149. {显示买卖数字}
  150. VAR100:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
  151. VAR110:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
  152. VAR120:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
  153. VAR130:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
  154. VAR140:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
  155. VAR150:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
  156. VAR160:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
  157. VAR170:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
  158. VAR180:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
  159. 买1:=VAR100;
  160. 买2:=(VAR110+VAR130+VAR150+VAR170);
  161. 卖1:=(VAR120+VAR140+VAR160+VAR180);
  162. PARTLINE(买1>0 OR 买2>0,LOW*0.99),CROSSDOT,LINETHICK3,COLORYELLOW;
  163. DRAWTEXT(买1>0 OR 买2>0,LOW*0.98,'买'),LINETHICK4,COLORRED;
  164. PARTLINE(卖1>0,HIGH*1.01),CROSSDOT,LINETHICK3,COLORGREEN;
  165. DRAWTEXT(卖1>0,HIGH*1.02,'卖'),LINETHICK4,COLORGREEN;
  166. {预测点位}
  167. hlq:=MA(REF(HIGH,1)/REF(CLOSE,2),Q1)*REF(CLOSE,1);
  168. hlq1:=MA(REF(LOW,1)/REF(CLOSE,2),Q1)*REF(CLOSE,1);
  169. hlq2:=MA(REF(HIGH,1)/REF(CLOSE,2),Q)*REF(CLOSE,1);
  170. hlq3:=MA(REF(LOW,1)/REF(CLOSE,2),Q)*REF(CLOSE,1);
  171. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,190,'【预测高位】'+NUMTOSTR(hlq2[SYSPARAM(1)],2)+'-'+NUMTOSTR(hlq[SYSPARAM(1)],2)+' 元'),colorYellow;
  172. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,160,'【预测低位】'+NUMTOSTR(hlq3[SYSPARAM(1)],2)+'-'+NUMTOSTR(hlq1[SYSPARAM(1)],2)+' 元'),colorYellow;
  173. {买卖点}
  174. 上涨值:=MA((HIGH+REF(LOW,1))/2,3);
  175. 买进高点:=MA((HIGH+REF(HIGH,1))/2,3);
  176. Var123:=((HIGH+LOW+CLOSE)/3)*2-LOW;
  177. 突破买入值:=MA(Var123,3);
  178. 下跌值:=MA((REF(HIGH,1)+LOW)/2,3);
  179. 卖出低点:=MA((REF(LOW,1)+LOW)/2,3);
  180. Var223:=((HIGH+LOW+CLOSE)/3)*2-HIGH;
  181. 突破卖出值:=MA(Var223,3);
  182. 买入价位:=(下跌值+卖出低点+突破卖出值+LOW)/4.1;
  183. 买入价位1:=(下跌值+卖出低点+突破卖出值+LOW)/3.94;
  184. 卖出价位:=(上涨值+买进高点+突破买入值+HIGH)/4.01;
  185. 卖出价位1:=(上涨值+买进高点+突破买入值+HIGH)/3.95;
  186. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,220,'【预测买入】'+NUMTOSTR(买入价位[SYSPARAM(1)],2)+'-'+NUMTOSTR(买入价位1[SYSPARAM(1)],2)+' 元'),COLORWHITE,PXUP0;
  187. DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,250,'【预测卖出】'+NUMTOSTR(卖出价位[SYSPARAM(1)],2)+'-'+NUMTOSTR(卖出价位1[SYSPARAM(1)],2)+' 元'),COLORWHITE,PXUP0;
  188. {点石成金光标划线}
  189. bc:=BARSLAST(SYSPARAM(1)=BARPOS)+1;
  190. 点石成金H:=IF(CLOSE>100,SUM(HIGH*VOL,bc)/SUM(VOL,bc),SUM(AMOUNT,bc)/SUM(VOL,bc)/100*SUM(HIGH,bc)/SUM(CLOSE,BC)),colorred,LINETHICK2;
  191. 点石成金L:=IF(CLOSE>100,SUM(LOW*VOL,bc)/SUM(VOL,bc),SUM(AMOUNT,bc)/SUM(VOL,bc)/100*SUM(LOW,bc)/SUM(CLOSE,BC)),colorblue,LINETHICK2;
  192. 点石成金:IF(REF(HIGH,bc-1)>REF(HIGH,bc) and REF(HIGH,bc-1)>REF(HIGH,bc-2) ,点石成金h,点石成金l),COLORYELLOW,LINETHICK3;
  193. {买卖数据}
  194. 特大买入:=STKINDI('','引用.特大买入',0,0);
  195. 特大卖出:=STKINDI('','引用.特大卖出',0,0);
  196. 大单买入:=STKINDI('','引用.大单买入',0,0);
  197. 大单卖出:=STKINDI('','引用.大单卖出',0,0);
  198. 小单买入:=STKINDI('','引用.小单买入',0,0);
  199. 小单卖出:=STKINDI('','引用.小单卖出',0,0);
  200. 总:=(特大买入+特大卖出+大单买入+大单卖出+小单买入+小单卖出);
  201. 散户跟风系数:=(小单买入-小单卖出)/总*100;
  202. DRAWTEXTEX(CLOSE,1,485,100,'【跟风系数】'+NUMTOSTR(散户跟风系数,2)+' %'),Color00FFFF;
  203. 流通:FINANCE(7)/10000,LINETHICK0,PRECISION2,colorBFFF;
  204. A:=STKINDI('','引用.特大买入',0,0);
  205. A1:=STKINDI('','引用.特大卖出',0,0);
  206. B:=STKINDI('','引用.隐性买单',0,0);
  207. B1:=STKINDI('','引用.隐性卖单',0,0);
  208. D:=STKINDI('','引用.大单买入',0,0);
  209. D1:=STKINDI('','引用.大单卖出',0,0);
  210. E:=STKINDI('','引用.中单买入',0,0);
  211. E1:=STKINDI('','引用.中单卖出',0,0);
  212. F:=STKINDI('','引用.小单买入',0,0);
  213. F1:=STKINDI('','引用.小单卖出',0,0);
  214. AA:=A-A1;
  215. BB:=B-B1;
  216. DD:=D-D1;
  217. EE:=E-E1;
  218. FF:=F-F1;
  219. DRAWTEXTEX(CLOSE,1,20,640,'■机构净买:'+NUMTOSTR(AA*100/10000,2)+' 万股'),COLORYELLOW;
  220. DRAWTEXTEX(CLOSE,1,20,670,'■特户净买:'+NUMTOSTR(BB*100/10000,2)+' 万股'),COLORYELLOW;
  221. DRAWTEXTEX(CLOSE,1,20,700,'■大户净买:'+NUMTOSTR(DD*100/10000,2)+' 万股'),COLORYELLOW;
  222. DRAWTEXTEX(CLOSE,1,20,730,'■中户净买:'+NUMTOSTR(EE*100/10000,2)+' 万股'),COLORYELLOW;
  223. DRAWTEXTEX(CLOSE,1,20,760,'■散户净买:'+NUMTOSTR(FF*100/10000,2)+' 万股'),COLORYELLOW;
  224. QS:=(AA+BB+DD);
  225. QS1:=QS*100*close/10000;
  226. DRAWTEXTEX(CLOSE,1,400,980,'今日主力净买: '+NUMTOSTR(QS1,2)+' 万元'),ColorFFBFFF;
  227. {周资金流向}
  228. 机构净买:=EXTDATA(9);
  229. 机值:=EXTDATA(9)*CLOSE/100;
  230. 券商净买:=EXTDATA(10);
  231. 券值:=EXTDATA(10)*CLOSE/100;
  232. 大户净买:=EXTDATA(11);
  233. 大值:=EXTDATA(11)*CLOSE/100;
  234. 资金流向:=机值+券值+大值;
  235. 周资金流向:=SUM(资金流向,5);
  236. DRAWTEXTEX(CLOSE,1,20,790,'周资金增减:'+NUMTOSTR(周资金流向,2)+' 万元'),COLORYELLOW;
  237. {显示时间}
  238. variable:wday[7]='星期六';
  239. wday[1]:='星期日';
  240. wday[2]:='星期一';
  241. wday[3]:='星期二';
  242. wday[4]:='星期三';
  243. wday[5]:='星期四';
  244. wday[6]:='星期五';
  245. fy:=YEAR;
  246. fm:=MONTH;
  247. fd:=DAY;
  248. wd:=WEEKDAY;
  249. str1:=''+NUMTOSTR(fy[p],0)+'年'+NUMTOSTR(fm[p],0)+'月'+NUMTOSTR(fd[p],0)+'日 '+wday[wd[p]+1];
  250. DRAWTEXTEX(CLOSE,1,100,980,str1),ColorFFBF00;</font>
复制代码

全景看盘主图指标 源码 飞狐

全景看盘主图指标 源码 飞狐

全景看盘主图指标 源码 飞狐

全景看盘主图指标 源码 飞狐

回复
0

使用道具 举报

懒得打字嘛,点击快捷回复 【回复乱码 永久禁言】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝21

帖子2847

发布主题
推荐素材更多+
广告位


QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1