开启左侧

凡倍无名 通达信技术指标 主图源码

[复制链接]
  1. AA05:MA(C,30);
  2. MA1:MA(CLOSE,30);
  3. MA2:MA(CLOSE,40);
  4. MA3:MA(CLOSE,50);
  5. MA4:MA(CLOSE,60);
  6. MA5:MA(CLOSE,70);
  7. MA6:MA(CLOSE,80);
  8. MA7:MA(CLOSE,90);
  9. MA8:MA(CLOSE,100);
  10. MA9:MA(CLOSE,110);
  11. MA10:MA(CLOSE,120);
  12. 五日乖离率:=(C-AA05)/AA05*100;
  13. BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
  14. 速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
  15. 加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;
  16. AA10:MA(C,30);AA20:=MA(C,30);
  17. BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
  18. AA30:MA(C,30);
  19. 三拾日乖离率:=(C-AA30)/AA30*100,LINETHICK0;
  20. VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
  21. VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
  22. BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
  23. 强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
  24. 加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
  25. AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
  26. 清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
  27. DRAWTEXT(加仓 ,LOW*0.98,'加仓'),COLORRED;
  28. JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
  29. 减仓:=FILTER(JC,10);
  30. MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
  31. 买入:=FILTER(MR,10);
  32. DRAWTEXT(减仓,HIGH*1.02,'减仓'),COLORCYAN;
  33. DRAWTEXT(买入,LOW*0.98,'买入'),COLORYELLOW;
  34. DRAWTEXT(清仓 ,HIGH*1.02,'清仓'),COLORGREEN;
  35. DRAWTEXT(强势狙击,LOW*0.98,'狙击'),COLORYELLOW;
  36. {以下是增加的K线文字解盘,可以删去不要}
  37. AAA:=CONST(HHV(H*0.5,90));
  38. A74:=MA(CLOSE,20);
  39. A75:=(CLOSE > MA(CLOSE,5));
  40. A76:=(MA(CLOSE,5) > MA(CLOSE,10));
  41. A77:=(CLOSE > MA(CLOSE,10));
  42. A78:=(MA(CLOSE,5) > MA(CLOSE,20));
  43. A79:=(CLOSE > MA(CLOSE,20));
  44. A710:=REF(A74,1);
  45. A711:=(A74 > A710);
  46. AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))
  47. + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
  48. DSLX:=(CLOSE / INDEXC);
  49. DSLX1:=MA(DSLX,5);
  50. DSLX2:=MA(DSLX,10);
  51. V1:=MA(VOL,5);
  52. V2:=MA(VOL,10);
  53. T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  54. T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  55. T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
  56. T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
  57. T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  58. T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  59. T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
  60. T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
  61. T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  62. T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  63. T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
  64. T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
  65. T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  66. T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  67. T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
  68. T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
  69. T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
  70. T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
  71. T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
  72. T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
  73. T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
  74. T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
  75. T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
  76. T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
  77. T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));

  78. {涨停柱红涨停兰跌停}
  79. C2:=REF(C,1);
  80. 涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
  81. STICKLINE(涨停,OPEN,CLOSE,2,0),COLOR0000FF;
  82. STICKLINE(涨停,H,L,0,0),COLOR0000FF;
  83. 跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
  84. STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
  85. STICKLINE(跌停,H,L,0,1),COLORGREEN;

  86. DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,CLOSE
  87. ,'量能理想,明显走强,中线参与,仓位在2/3左右。'),COLORFF00FF  ;
  88. DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,CLOSE
  89. ,'走势趋强,还显不足,短线进场,仓位在1/2左右。'),COLORFFFFFF  ;
  90. DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,CLOSE
  91. ,'量价良好,没有明显走强,短线进场,仓位1/2左右。'),COLORFFFFFF  ;
  92. DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,CLOSE
  93. ,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右。'),COLORFFFFFF  ;
  94. DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,CLOSE
  95. ,'形态变坏,重仓者减持大半,清仓者观望。'),COLORFFFFFF  ;
  96. DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,CLOSE
  97. ,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓。'),COLORFFFFFF  ;
  98. DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,CLOSE
  99. ,'该股放量下跌,走势明显偏弱,离场观望。'),COLORFFFFFF  ;
  100. DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,CLOSE
  101. ,'该股缩量下跌,走势偏弱,离场观望。'),COLORFF00FF  ;
  102. DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,CLOSE
  103. ,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLORFFFFFF  ;
  104. DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,CLOSE
  105. ,'上行趋势不变,强势依然,量能开始转弱,注意风险。'),COLORFFFFFF  ;
  106. DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,CLOSE
  107. ,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),COLORFFFFFF  ;
  108. DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,CLOSE
  109. ,'该股走势趋弱,量能不足,减持大部分筹码。'),COLORFFFFFF  ;
  110. DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,CLOSE
  111. ,'该股形态不佳,注意成交量的变化,目前不适合参与。'),COLORFFFFFF  ;
  112. DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,CLOSE
  113. ,'趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),COLORFFFFFF  ;
  114. DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,CLOSE
  115. ,'有走强迹象,但量能不足,趋势不明,不适合操作。'),COLORFFFFFF  ;
  116. DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,CLOSE
  117. ,'该股走势太弱,没有参与价值。'),COLORFF00FF  ;
  118. DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,CLOSE
  119. ,'大盘理想,有明显走强迹象,中线参与,仓位在2/3左右。'),COLORFFFFFF  ;
  120. DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,CLOSE
  121. ,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎。'),COLORFFFFFF  ;
  122. DRAWTEXT(T19=1 AND CURRBARSCOUNT=120,CLOSE
  123. ,'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入。'),COLORFFFFFF  ;
  124. DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,CLOSE
  125. ,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORFF0000  ;
  126. DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,CLOSE
  127. ,'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000  ;
  128. DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,CLOSE
  129. ,'大盘走势良好,量能理想,可以继续持有强势股。'),COLORFF0000  ;
  130. DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,CLOSE
  131. ,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLORFF0000  ;
  132. DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,CLOSE
  133. ,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFF0000  ;
  134. DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,CLOSE
  135. ,'大盘趋势向下,量能萎缩,不适合进场。'),COLORFF0000  ;
  136. 压力:MA(REF(HHV(C,30),1),2),COLORBLUE,DOTLINE,LINETHICK2;
  137. DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK),COLORYELLOW;
  138. DRAWTEXT_FIX(ISLASTBAR,0.08,0,0,DYBLOCK),COLORYELLOW;
  139. DRAWTEXT_FIX(ISLASTBAR,0.16,0,0,GNBLOCK),COLORYELLOW;
  140. BB:REF(V,BARSLAST(TIME>=92500 AND TIME<=93000));
  141. DRAWTEXT_FIX(ISLASTBAR,0.24,0,0,BB),COLORYELLOW;
复制代码

凡倍无名 通达信技术指标 主图源码

凡倍无名 通达信技术指标 主图源码

回复
0

使用道具 举报

懒得打字嘛,点击快捷回复 【回复乱码 永久禁言】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝1

帖子951

发布主题
推荐素材更多+
广告位


QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1