开启左侧

支撑上穿压力主图指标 源码 通达信

[复制链接]
支撑上穿压力 就是图中黄穿红就进入
  1. 买线:=EMA(C,1);
  2. 卖线:=EMA(SLOPE(C,10)*10+C,20);
  3. STICKLINE(买线>=卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR000000;
  4. STICKLINE(买线<卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR232323;
  5. DRAWKLINE(H,O,L,C);{波段淡红青K线}
  6. STICKLINE(买线>=卖线,C,O,3,0),COLOR000045;
  7. STICKLINE(买线>=卖线,C,O,2,0),COLOR000085;
  8. STICKLINE(买线>=卖线,C,O,1,0),COLOR0000C5;
  9. STICKLINE(买线>=卖线,C,O,0.3,0),COLOR0000E5;
  10. STICKLINE(买线>=卖线,L,H,0,0),COLOR0000FF;
  11. STICKLINE(买线<卖线,L,H,0,0 ),COLORFFFF00;
  12. STICKLINE(买线<卖线,C,O,3.1,0 ),COLOR000000;
  13. STICKLINE(买线<卖线,C,O,2.1,0 ),COLOR6A6A00;
  14. STICKLINE(买线<卖线,C,O,1.5,0 ),COLORDDDD00;
  15. STICKLINE(买线<卖线,C,O,0.3,0),COLORFFFF00;
  16. DRAWICON(CROSS(买线,卖线),L,42);
  17. DRAWICON(CROSS(卖线,买线),H,43);
  18. XG1:=C/REF(C,1)>1.05;
  19. STICKLINE(XG1,L,H,0,0),COLOR0088EE;
  20. STICKLINE(XG1,CLOSE,OPEN,3,0),COLOR000000;
  21. STICKLINE(XG1,CLOSE,OPEN,2.2,0),COLOR0088DD;
  22. STICKLINE(XG1,CLOSE,OPEN,1.2,0),COLOR00AAFF;
  23. STICKLINE(XG1,CLOSE,OPEN,0.3,0),COLOR00FFFF;
  24. 均价:=(3*C+H+L+O)/6;
  25. VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+
  26. 4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
  27. VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
  28. SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;
  29. SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
  30. AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;
  31. SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;
  32. SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
  33. AND CLOSE>VAR2 AND CLOSE<VAR1;
  34. SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)
  35. AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1)
  36. AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);
  37. SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;
  38. XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)
  39. AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);
  40. XD2:=VAR1=VAR2 AND CLOSE>VAR1;
  41. SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
  42. 量能饱和度:=IF(SAT>1,1,SAT)*100;
  43. DRAWTEXT_FIX(BARSTATUS=2 AND SZ1,0.8,0.05,0,'调整结束短线介入'),COLORFFFFFF;
  44. DRAWTEXT_FIX(BARSTATUS=2 AND SZ2,0.8,0.05,0,'上升通道走势良好'),COLORFFFFFF;
  45. DRAWTEXT_FIX(BARSTATUS=2 AND SZ3,0.8,0.05,0,'股价偏离注意调整'),COLORFFFFFF;
  46. DRAWTEXT_FIX(BARSTATUS=2 AND SZ4,0.8,0.05,0,'上升通道调整洗盘'),COLORFFFFFF;
  47. DRAWTEXT_FIX(BARSTATUS=2 AND SZ5,0.8,0.05,0,'转向特征注意离场'),COLOR00FFFF;
  48. DRAWTEXT_FIX(BARSTATUS=2 AND SZ6,0.8,0.05,0,'通道改变坚决离场'),COLORFFFF00;
  49. DRAWTEXT_FIX(BARSTATUS=2 AND XD1,0.8,0.05,0,'下跌通道只宜观望'),COLORFFFF00;
  50. DRAWTEXT_FIX(BARSTATUS=2 AND XD2,0.8,0.05,0,'短期底部准备进入'),COLORYELLOW;
  51. RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
  52. K:=SMA(RSV,3,1);
  53. D:=SMA(K,3,1);
  54. J:=3*K-2*D;
  55. RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
  56. K24:=SMA(RSV24,3,1);
  57. D24:=SMA(K24,3,1);
  58. J24:=3*K24-2*D24;
  59. 压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),DOTLINE,COLORRED;
  60. 支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),DOTLINE,COLOR77AAFF;
  61. HH:=CONST(HHV(C,0));
  62. LL:=CONST(LLV(C,0));
  63. HL:=HH-LL;
  64. 顶:HH,NODRAW;
  65. DRAWICON(C=HH,HH,45);
  66. DRAWICON(C=LL,LL,44);
  67. {前期机构:=STRCAT(STRCAT('前期 机构(家): ',CON2STR(FINONE(246,0,331),0)),STRCAT(' 持股数(股): ',CON2STR(FINONE(247,0,331),0)));
  68. 本期机构:=STRCAT(STRCAT('本期 机构(家): ',CON2STR(FINONE(246,0,0),0)),STRCAT(' 持股数(股): ',CON2STR(FINONE(247,0,0),0)));
  69. DRAWTEXT_FIX(ISLASTBAR,0,0,0,前期机构),COLORFFFFFF;
  70. DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,本期机构),COLORFFFFFF;
  71. 前期股东:=STRCAT('前期 十大流东股东持股 合计 : ',CON2STR(FINONE(264,0,331),0));
  72. 本期股东:=STRCAT('本期 十大流东股东持股 合计: ',CON2STR(FINONE(264,0,0),0));
  73. DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,前期股东),COLORYELLOW;
  74. DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,本期股东),COLORYELLOW;};
复制代码

支撑上穿压力主图指标 源码 通达信

支撑上穿压力主图指标 源码 通达信



回复
0

使用道具 举报

懒得打字嘛,点击快捷回复 【回复乱码 永久禁言】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝1

帖子957

发布主题
推荐素材更多+
广告位


QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1