开启左侧

回调突破主图指标 源码 通达信 珍藏的一直在用的操盘主图

[复制链接]
非常实用的一个操盘主图,按照提示操作,买卖点提示。

  1. B1:=MA(C,1);
  2. B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
  3. SMA2:=MA(B2,3);
  4. 停损下限:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
  5. IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;
  6. IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK4;
  7. SNAKEA:HHV(MA(B2,1),13),COLORYELLOW;
  8. VAR1A:=(2*CLOSE+HIGH+LOW)/4;
  9. VAR2A:=MA(VAR1A,7);
  10. VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
  11. VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
  12. VAR5A:=BARSLAST(VAR3A);
  13. VAR6A:=0-BARSLAST(VAR4A);
  14. VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
  15. STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;
  16. STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA,SMA2,0,0),COLORBLUE;
  17. VAR11A:=(CLOSE*2+HIGH+LOW)/4;
  18. VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
  19. VAR31A:=EMA(VAR21A,5);
  20. {STICKLINE((C>=O),OPEN,LOW,0,0),COLOR0726CA;
  21. STICKLINE((C>=O),CLOSE,HIGH,0,0),COLOR0726CA;
  22. STICKLINE((C<O),CLOSE,LOW,0,0),COLORDE9100;
  23. STICKLINE((C<O),OPEN,HIGH,0,0),COLORDE9100;
  24. STICKLINE((C<O),CLOSE,OPEN,2.5,0),COLORFFCC00;
  25. STICKLINE((C<O),CLOSE,OPEN,1.5,0),COLORFFFF00;
  26. STICKLINE((C>O),CLOSE,OPEN,2,0),COLOR0754E9;
  27. STICKLINE((C>O),CLOSE,OPEN,1.5,0),COLOR076EF3;
  28. STICKLINE((C>O),CLOSE,OPEN,1,0),COLOR077BF3;}
  29. VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
  30. VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  31. VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  32. VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  33. VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  34. VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  35. VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  36. VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  37. VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  38. VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  39. VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  40. VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  41. VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
  42. VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  43. VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  44. VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  45. VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  46. VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  47. VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  48. VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  49. VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  50. VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  51. VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
  52. VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
  53. VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
  54. {STICKLINE(VAR1B,O,O+(C-O)/3,3,0),COLOR10D0FF;}
  55. STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR10FFFF;
  56. STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
  57. AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
  58. {STICKLINE(AA,O,O+(C-O)/3,3,0),COLOR00DD00;}
  59. STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;
  60. STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;
  61. A13:=EMA(CLOSE,55);
  62. A14:=MA(CLOSE,75);
  63. A15:=EMA(A14,3);
  64. A16:=EMA(A15,3);
  65. A17:=(HIGH + LOW) / 5;
  66. A18:=(MA(A17,4)) - (MA(A17,34));
  67. A19:=CROSS(A18,0);
  68. A20:=CROSS(0,A18);
  69. A21:=BARSLAST(A19);
  70. A22:=BARSLAST(A20);
  71. A23:=REF(A19,1);
  72. A24:=REF(A20,1);
  73. A25:=BARSLAST(A23);
  74. A26:=BARSLAST(A24);
  75. A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
  76. A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);
  77. A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);
  78. A30:=A28 AND ((COUNT(A28,A21)) = 1);
  79. A31:=A29 AND ((COUNT(A29,A22)) = 1);
  80. A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
  81. A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));
  82. DRAWTEXT(A32,SMA2*0.99,'←═≒∝'),COLORYELLOW;
  83. AC:=AMOUNT/(VOL);
  84. YY:=MA(AC,13);
  85. LLL:=(C-YY)/YY*100;
  86. MIDC := MA(CLOSE,22);
  87. UPPERC:= MIDC + 2*STD(C,22);
  88. LOWERC:= MIDC - 2*STD(C,22);
  89. BBA:=(C-LOWERC)/(UPPERC-LOWERC);
  90. BBC:=FORCAST(BBA,3);
  91. LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
  92. {//STICKLINE(LIFENGCYC,BBC,0.5,6,0);}
  93. {/BBD:(UPPER+LOWER)/2*(C-UPPER);}
  94. STICKLINE(LIFENGCYC>0,C,O,2,0),COLOR10ABFF;
  95. {STICKLINE(LIFENGCYC>0,C,O,1.5,0),COLOR10D0FF;
  96. STICKLINE(LIFENGCYC>0,C,O,1,0),COLOR10FFFF;}
  97. DRAWTEXT(LIFENGCYC>0,LOW*0.99,'☆'),COLORDD00DD;
  98. TJ:=DYNAINFO(4)>0
  99. AND HHV(HIGH,10)/LLV(LOW,10)<1.25
  100. AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)
  101. AND CLOSE>OPEN
  102. AND CLOSE>=HHV(HIGH,10);
  103. STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,1,0),COLORYELLOW;
  104. 放量突破:TJ,NODRAW,COLORRED;
  105. DRAWTEXT(TJ,L-0.3,'放量突破'),COLORRED;
  106. W1:=C=HHV(C,20);
  107. W2:=BARSLAST(W1);
  108. W3:=IF(W2>0,REF(C,W2),REF(C,W2));
  109. W4:=CROSS(C,REF(W3,1));
  110. 回调突破:=W4 AND COUNT(W4,5)=1;
  111. DRAWTEXT(回调突破>0,MA(L,3),'*回调突破'),COLORYELLOW;
  112. 敢死队操作线:MA(C,24),LINETHICK2,COLORLIMAGENTA;
复制代码

回调突破主图指标 源码

回调突破主图指标 源码

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝21

帖子2733

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1