开启左侧

建仓与平仓主图指标 源码 通达信

[复制链接]
  1. MA5:MA(C,5);
  2. MA6:=MA(C,6);
  3. MA10:MA(C,10);
  4. MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
  5. MA30:MA(C,30);
  6. MA60:MA(C,60);
  7. MA120:MA(C,120);DRAWKLINE(H,O,L,C);
  8. 乖离2:=(MA20-MA30)/MA30*100;
  9. VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
  10. MAX1:=MAX(MA20,MA30);
  11. MAX2:=MAX(MAX1,MA60);
  12. MIN11:=MIN(MA20,MA30);
  13. MIN2:=MIN(MIN11,MA60);
  14. K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
  15. VAR2:=IF(K1<=8,1,0);
  16. 上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;
  17. STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;
  18. 神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
  19. ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,'←神枪手');
  20. 神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
  21. ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);{44.40%15240}
  22. 短线暴张:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
  23. AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,'短线暴张'),COLORRED;
  24. DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,'←注意变盘'),COLORYELLOW;
  25. DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,'←卖出'),COLORGREEN;
  26. DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
  27. DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;
  28. XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
  29. XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
  30. XL3:=CROSS(XL2,(0 - 20));
  31. X6:=REF(CLOSE,1);
  32. X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
  33. X8:=CROSS(79,X7);
  34. X9:=FILTER(X8,4);
  35. DRAWTEXT(X9,(HIGH * 1.02),'●出货'),COLOR9000F5;
  36. STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
  37. AAA:=CONST(HHV(H,90));
  38. LC:=REF(CLOSE,1);
  39. RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
  40. FF:=EMA(CLOSE,3);
  41. MA15:=EMA(CLOSE,21);
  42. DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'平仓'),COLORGREEN;
  43. VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
  44. VAR12:=(HIGH+LOW+CLOSE)/3;
  45. VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
  46. VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
  47. VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
  48. VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
  49. VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
  50. VAR18:=100-ABS(VAR17);
  51. VAR19:=IF(VAR18<90,VAR18,100);
  52. VAR1A:=IF(VARE>0,VARE,0);
  53. VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
  54. VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
  55. AA1:=AMOUNT/V;
  56. BB1:=L<AA1*0.9;
  57. CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
  58. DD1:=L<MA(C,5)*0.921;
  59. EE1:=V<MA(V,5)*1.5;
  60. A74:=MA(CLOSE,20);
  61. A75:=(CLOSE > MA(CLOSE,5));
  62. A76:=(MA(CLOSE,5) > MA(CLOSE,10));
  63. A77:=(CLOSE > MA(CLOSE,10));
  64. A78:=(MA(CLOSE,5) > MA(CLOSE,20));
  65. A79:=(CLOSE > MA(CLOSE,20));
  66. A710:=REF(A74,1);
  67. A711:=(A74 > A710);
  68. AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))
  69. + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
  70. DSLX:=(CLOSE / INDEXC);
  71. DSLX1:=MA(DSLX,5);
  72. DSLX2:=MA(DSLX,10);
  73. V1:=MA(VOL,5);
  74. V2:=MA(VOL,10);
  75. T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  76. T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  77. T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
  78. T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
  79. T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  80. T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  81. T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
  82. T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
  83. T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  84. T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  85. T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
  86. T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
  87. T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
  88. T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
  89. T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
  90. T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
  91. T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
  92. T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
  93. T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
  94. T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
  95. T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
  96. T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
  97. T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
  98. T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
  99. T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
  100. DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  101. ,'量能理想,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF ;
  102. DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  103. ,'走势趋强,还显不足,短线进场,仓位在1/2左右'),COLORFF00FF ;
  104. DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  105. ,'量价良好,没有明显走强,短线进场,仓位1/2左右'),COLORFF00FF ;
  106. DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  107. ,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右'),COLORFF00FF ;
  108. DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  109. ,'形态变坏,重仓者减持大半,清仓者观望'),COLORFF00FF ;
  110. DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,AAA*0.98
  111. ,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓'),COLORFF00FF ;
  112. DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  113. ,'该股放量下跌,走势明显偏弱,离场观望'),COLORFF00FF ;
  114. DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  115. ,'该股缩量下跌,走势偏弱,离场观望。'),COLORFF00FF ;
  116. DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  117. ,'该股形态良好,强势明显,量能充足,可以继续持有'),COLORFF00FF ;
  118. DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  119. ,'上行趋势不变,强势依然,量能开始转弱,注意风险'),COLORFF00FF ;
  120. DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  121. ,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓'),COLORFF00FF ;
  122. DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  123. ,'该股走势趋弱,量能不足,减持大部分筹码'),COLORFF00FF ;
  124. DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  125. ,'该股形态不佳,注意成交量的变化,目前不适合参与'),COLORFF00FF ;
  126. DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  127. ,'趋势不明,股价偏弱,注意量能变化,目前不宜参与'),COLORFF00FF ;
  128. DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  129. ,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFF00FF ;
  130. DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  131. ,'该股走势太弱,没有参与价值。'),COLORFF00FF ;
  132. DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  133. ,'大盘理想,有明显走强迹象,中线参与,仓位在2/3左右'),COLORFF00FF ;
  134. DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  135. ,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎'),COLORFF00FF ;
  136. DRAWTEXT(T19=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  137. ,'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入'),COLORFF00FF ;
  138. DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  139. ,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORFF0000 ;
  140. DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  141. ,'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000 ;
  142. DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  143. ,'大盘走势良好,量能理想,可以继续持有强势股。'),COLORFF0000 ;
  144. DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  145. ,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLORFF0000 ;
  146. DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  147. ,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFF0000 ;
  148. DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
  149. ,'大盘趋势向下,量能萎缩,不适合进场。'),COLORFF0000 ;
  150. AA:=BARSCOUNT(C);
  151. AH:=HHV(H,200);
  152. AL:=LLV(L,200);
  153. A0:=(AH-AL)/40;
  154. B1:=L-A0;
  155. VAR2S:=(2*CLOSE+HIGH+LOW)/4;
  156. VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
  157. VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
  158. 散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
  159. BBB1:=MA(C,1);
  160. B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;
  161. SMA2:=MA(B2,2);
  162. VARB1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
  163. VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
  164. 买:DRAWTEXT(CROSS(VARB1,VAR3) AND B2>SMA2,(LOW * 0.97),'←建仓'),COLORYELLOW;
复制代码

建仓与平仓主图指标

建仓与平仓主图指标

建仓与平仓主图指标

建仓与平仓主图指标

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝0

帖子2015

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1