开启左侧

洗盘回调介入主图指标 通达信 源码

[复制链接]
  1. {洗盘回调介入}

  2. T11:=CONST(LLVBARS(LOW,10));
  3. T11HIGH:=CONST(REF(HIGH,T11));
  4. CC1:=CONST(CURRBARSCOUNT);
  5. T22:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T11 AND H>T11HIGH));
  6. T22HIGH:=CONST(REF(HIGH,T22));
  7. T33:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T22 AND HIGH>T22HIGH));
  8. T33HIGH:=CONST(REF(HIGH,T33));
  9. {C>=T33HIGH AND REF(C,1)<T33HIGH AND DYNAINFO(17)>2;}
  10. N:=10;
  11. T1K:=CONST(LLVBARS(LOW,N));
  12. T1HIGH:=CONST(REF(HIGH,T1K));
  13. CC:=CONST(CURRBARSCOUNT);
  14. T2K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1K)) AND (HIGH>T1HIGH)));
  15. T2HIGH:=CONST(REF(HIGH,T2K));
  16. T3K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2K)) AND (HIGH>T2HIGH)));
  17. T3HIGH:=CONST(REF(HIGH,T3K));
  18. 洗盘杀入线:DRAWLINE(CURRBARSCOUNT=10+1,T3HIGH,ISLASTBAR, T3HIGH,1),LINETHICK1,COLORLIRED;
  19. DRAWTEXT(ISLASTBAR, T3HIGH,'杀入线')LINETHICK1,COLORLIRED;
  20. DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
  21. LC:=REF(CLOSE,1);
  22. RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
  23. FF:=EMA(CLOSE,3);
  24. MA15:=EMA(CLOSE,21);
  25. 回调:MA(CLOSE,10000);
  26. 买线:EMA(C,2),COLORRED;
  27. 卖线:EMA(SLOPE(C,21)*20+C,42),COLORGREEN;
  28. 指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),LINETHICK1,COLORFFFFFF;
  29. 界: MA(CLOSE,27),LINETHICK1,COLOR00FFFF;
  30. {STICKLINE((MA15 > REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,COLOR0000FF;}
  31. {STICKLINE((MA15 < REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,COLORFF0000;}
  32. DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'上拐点'),COLOR00FFFF;
  33. DRAWTEXT(CROSS(MA15,FF),(HIGH * 1.02),'下拐点'),COLOR00FF00;
  34. DRAWTEXT(CROSS(85,RSI),(HIGH * 1.02),'回调!'),COLORFFFFFF;
  35. BU:=CROSS(买线,卖线);
  36. SEL:=CROSS(卖线,买线);
  37. STICKLINE(买线>=卖线,CLOSE,OPEN,2.5,0),COLOR0000AA;
  38. STICKLINE(买线>=卖线,CLOSE,OPEN,2,0),COLOR0000CC;
  39. STICKLINE(买线<卖线,CLOSE,OPEN,2.5,0),COLORAAAA00;
  40. STICKLINE(买线<卖线,CLOSE,OPEN,2,0),COLORBBBB00;
  41. STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,1.5,0),COLOR00FFFF;
复制代码

洗盘回调介入主图指标

洗盘回调介入主图指标



回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝0

帖子2015

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1