开启左侧

做T神器分时T0主图指标 源码 通达信 无密码

[复制链接]
● 支撑线(绿线) 压力线(红线)
● 买入:股价到达支撑线,第1次买点信号出现后,激进者可介入。
第2次买点信号出现后,但股价持平或高于第1次买入信号出现时的股价,稳健者可介入。
● 卖出:只要有的挣,在哪里卖都是对的,当然,可以参考第一次出现的卖点信号出货。

  1. XG:HHV(H,480),DOTLINE,COLORCYAN;
  2. RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
  3. JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
  4. MA1:=REF(C,JY);
  5. MA2:=REF(MA1,JY);
  6. MA3:=REF(MA2,JY);
  7. MA4:=REF(MA3,JY);
  8. MA5:=REF(MA4,JY);
  9. MA6:=REF(MA5,JY);
  10. MA7:=REF(MA6,JY);
  11. MA8:=REF(MA7,JY);
  12. MA9:=REF(MA8,JY);
  13. H1:=MAX(DYNAINFO(3),DYNAINFO(5));
  14. L1:=MIN(DYNAINFO(3),DYNAINFO(6));
  15. P1:=H1-L1;
  16. 阻力:L1+P1*8/9,COLORLIRED,DOTLINE;
  17. 支撑:L1+P1*0.5/9,COLORGREEN,DOTLINE;
  18. 均线:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW,DOTLINE;
  19. DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);
  20. DEA:=EMA(DIF,9);
  21. MACD1:=10*(DIF-DEA);
  22. MACD2:=EMA(MACD1,2);
  23. STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGRAY;
  24. STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLICYAN;
  25. STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGRAY;
  26. STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGREEN;
  27. XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
  28. 主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
  29. 底:=1;1.022,NODRAW;高:=1.033;
  30. DRAWTEXT(CROSS(主力,1.02),C*0.999,' 拉'),COLORMAGENTA;
  31. DRAWICON(CROSS(主力,1.04),C,45);
  32. DRAWTEXT(CROSS(主力,1.04),C*0.999,' 冲'),COLORRED;
  33. A1:=(VOL/CLOSE)/3;
  34. A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
  35. A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
  36. A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
  37. A5:=SUM((IF(((A1<40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
  38. A6:=((A2+A3)+A4)+A5;
  39. A7:=IF((BARSTATUS=2),((100*A2)/A6),0);
  40. A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));
  41. A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));
  42. A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));
  43. DRAWTEXT(LONGCROSS(支撑,C,2),C-0.01,' 买入'),COLOR0000FF;
  44. DRAWICON(LONGCROSS(支撑,C,2),C-0.01,1);
  45. STICKLINE(LONGCROSS(支撑,C,2),C,阻力,0,-1),COLORCYAN;
  46. DRAWTEXT(LONGCROSS(C,阻力,2),C+0.01,' 卖出'),COLORGREEN;
  47. DRAWICON(LONGCROSS(C,阻力,2),C+0.01,45);
  48. STICKLINE(LONGCROSS(C,阻力,2),C,支撑,0,-1),COLORRED;
  49. 量价:=(VOL/CLOSE)/3;
  50. B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
  51. B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
  52. B6:=B2+B3;DD1:=1;比:=B2/B3;
  53. D1:=YEAR AND MONTH AND DAY;
  54. BA1:=STRCAT(CON2STR(YEAR,0),'年');
  55. BA2:=STRCAT(CON2STR(MONTH,0),'月');
  56. BA3:=STRCAT(CON2STR(DAY,0),'日');
  57. BA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
  58. AA:=STRCAT(STRCAT(STRCAT(BA1,BA2),STRCAT(BA3,BA4)),'');
  59. DRAWTEXT_FIX(D1,0.905,0,0,AA),COLORGRAY;
  60. WA1:=V*C/100;
  61. WA2:=SUM((IF(((WA1/8>20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
  62. WA3:=SUM((IF(((WA1/8>20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
  63. WA4:=SUM((IF(((WA1/8<20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
  64. WA5:=SUM((IF(((WA1/8<20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
  65. WA6:=((A2+A3)+A4)+A5;
  66. WA7:=IF((ISLASTBAR),((100*WA2)/WA6),0);
  67. WA8:=IF((ISLASTBAR),((100*WA3)/WA6),0);
  68. WA9:=IF((ISLASTBAR),((100*WA4)/WA6),0);
  69. WA10:=IF((ISLASTBAR),((100*WA5)/WA6),0);
  70. 机构买盘:=(WA2);
  71. 机构卖盘:=(WA3);
  72. 散户买盘:=(WA4);
  73. 散户卖盘:=(WA5);
  74. DRAWTEXT_FIX(1,0.752,1-0.088,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),' 万')),COLORRED;
  75. DRAWTEXT_FIX(1,0.752,1-0.001,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),' 万')),COLORGREEN;
  76. DRAWTEXT_FIX(1,0.883,1-0.088,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),' 万')),COLORMAGENTA;
  77. DRAWTEXT_FIX(1,0.883,1-0.001,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),' 万')),COLORCYAN;
复制代码

做T神器分时T0主图指标

做T神器分时T0主图指标

做T神器分时T0主图指标

做T神器分时T0主图指标

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1