开启左侧

飞龙在天主图指标 源码 通达信

[复制链接]
  1. {LL 0 35 20
  2. LH 65 100 80}

  3. 涨停:=IF(REF(C,1)*1.1-C<0.2 ,1,0);
  4. STICKLINE(涨停,OPEN,CLOSE,4,2),COLORRED;
  5. STICKLINE(涨停,OPEN,CLOSE,0.8,0),COLORMAGENTA;
  6. STICKLINE(涨停,H,L,0,0),COLORMAGENTA;
  7. ZT:=C/REF(C,1)>1.095;
  8. STICKLINE(MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND ZT,O,C,0.9,0),COLORMAGENTA;
  9. STICKLINE(MA(CLOSE,5)<=REF(MA(CLOSE,5),1) AND ZT,O,C,0.6,0),COLORMAGENTA;
  10. VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
  11. VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
  12. DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.91),'乘龙去 '),COLOR00FFFF;
  13. {归隐} LC:=REF(CLOSE,1); RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
  14. 归隐:=CROSS(80,RSI5);
  15. DRAWICON(归隐,H*1.015,2);
  16. DRAWTEXT(归隐,H*1.025,'归隐')COLORGREEN;
  17. VAR121:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
  18. VAR141:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
  19. VAR161:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
  20. VAR181:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
  21. 卖线:=(VAR121+VAR141+VAR161+VAR181);
  22. 压力平台:DRAWLINE(卖线,(C+O)*0.508,BARSLAST(卖线)>=1,REF((C+O)*0.508,BARSLAST(卖线)),1),LINETHICK2,COLORBLUE,;

  23. 飞龙:EMA(COST(80),13)COLORYELLOW;
  24. 云层:MA(C,100)COLORRED;

  25. 持股:MA(C,8)COLORWHITE;
  26. YJ:=持股;
  27. IF(YJ*1.008>REF(YJ,1),YJ,DRAWNULL),COLORYELLOW,LINETHICK2;

  28. IF(YJ>REF(YJ,1),YJ,DRAWNULL),COLORRED,LINETHICK2;
  29. 持币:MA(C,13)COLORFFFF33,POINTDOT;


  30. NOTEXTJ3:=MA(C,3);
  31. DRAWICON(CROSS(NOTEXTJ3,持股) AND H>持股 AND C/O>=1.02,L*0.97,1);
  32. DRAWTEXT(CROSS(NOTEXTJ3,持股) AND H>持股 AND C/O>=1.02,L*0.94,'腾云')COLORYELLOW;


  33. SR1X:=REF(HIGH,10)=HHV(HIGH,2*10+1);
  34. SR2X:=FILTER(SR1X,10);
  35. SR3X:=BACKSET(SR2X,10+1);
  36. HDX:=FILTER(SR3X,10);
  37. 前高X:=REF(H,BARSLAST(HDX));
  38. 倍量X:=VOL/REF(VOL,1)>=1.9;
  39. 突破前高X:=CROSS(C,前高X);
  40. Y2:= 倍量X AND 突破前高X;
  41. YY2:= 倍量X AND C>O;
  42. SJ:=BARSLAST(Y2);
  43. {STICKLINE(YY2,OPEN,CLOSE,3,0),COLORYELLOW;
  44. DRAWTEXT(YY2,L*0.955,''),COLORYELLOW;}
  45. STICKLINE(Y2,OPEN,CLOSE,3,0),COLORYELLOW;
  46. DRAWTEXT(Y2,L*0.955,'倍量过左峰'),COLORYELLOW;

  47. {LC:=REF(CLOSE,1);}
  48. WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
  49. 买:=CROSS(WRSI,LL)COLORRED;
  50. 卖:=CROSS(LH,WRSI)COLORGREEN;
  51. DRAWICON(买 AND H>=持股,L*0.97,1);
  52. DRAWTEXT(买 AND H>=持股,L*0.94,'腾云')COLORYELLOW;
  53. DRAWICON(卖,H*1.015,2);


  54. {驾雾}
  55. A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
  56. 驾雾线:=EMA(A51,5);A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
  57. 趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
  58. HMHM:=CROSS(趋势线,0)AND 驾雾线<40;
  59. DRAWICON(FILTER(HMHM,10),L*0.99,1);
  60. DRAWTEXT(FILTER(HMHM,10),L*0.97,'驾雾'),COLORYELLOW,LINETHICK1;
  61. DRAWTEXT(REF(C,1)<飞龙 AND C>飞龙 AND 持股<飞龙,H*1.02,'飞龙跃起')COLORYELLOW;
  62. DRAWTEXT(REF(C,1)<飞龙 AND C>飞龙 AND 持股>飞龙,H*1.02,'飞龙在天')COLORYELLOW;
  63. TC1:=IF(H=HHV(H,48),H,DRAWNULL);
  64. TC2:=CONST(BARSLAST(TC1=H))+1;
  65. UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
  66. BC1:=IF(L=LLV(L,48),L,DRAWNULL);
  67. BC2:=CONST(BARSLAST(BC1=L))+1;

  68. LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
  69. LP:=CURRBARSCOUNT<=BC2 AND L=LOWER;{低点定位}
  70. HP:=CURRBARSCOUNT<=TC2 AND H=UPPER;{高点定位}
  71. 波段底:=IF(LP,150,0),COLORMAGENTA;
  72. DRAWTEXT(FILTER(波段底,10),L*0.965,'捣龙窝'),COLORBLUE,LINETHICK1;
  73. {昨天的大于7%和涨停的阳线的实体的1/4位、1/2位、3/4位画上横线。}
  74. STICKLINE(C/REF(C,1)>=1.07,(C+O)/2,(C+O)/2,2,1),COLORLIBLUE;{中分线};
  75. STICKLINE(C/REF(C,1)>=1.07,(MAX(O,C)-MIN(O,C))*3/4+MIN(O,C),(MAX(O,C)-MIN(O,C))*3/4+MIN(O,C),2,1),COLORLIBLUE;
  76. STICKLINE(C/REF(C,1)>=1.07,(MAX(O,C)-MIN(O,C))/4+MIN(O,C),(MAX(O,C)-MIN(O,C))/4+MIN(O,C),2,1),COLORLIBLUE;
  77. N1:=9;RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORWHITE,NODRAW;
  78. RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
  79. FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);
  80. DDD:DRAWTEXT(CROSS(FF,MA15),(LOW * 0.96),'底背'),COLORFFFF33;
  81. DDDD:DRAWTEXT(CROSS(88,RSI),(HIGH * 1.034),'顶背'),COLOR1880FF;
复制代码

飞龙在天主图指标

飞龙在天主图指标

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝1

帖子1193

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1