开启左侧

三线共振副图指标 源码 通达信 无未来函数

[复制链接]
  1. ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
  2. SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
  3. ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
  4. ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
  5. ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
  6. ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
  7. ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
  8. ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
  9. ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
  10. SH8:=EMA(ZSHTL,8);
  11. DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
  12. {散户筹码警戒}
  13. STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,2,0),COLOR00FF00;
  14. {顶部:(ZZLKP>75),COLORFFFFFF;}
  15. {主力筹码警戒}
  16. STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,2,0),COLORRED;
  17. 实心红柱:(ZZLJJ>REF(ZZLJJ,1))>0,COLORRED;
  18. 散筹因子:INTPART(ZSHTL),COLORCYAN,LINETHICK1;
  19. 主筹因子:INTPART(ZZLKP),COLORWHITE,LINETHICK1;
  20. 0,DOTLINE,COLORGRAY;
  21. 20,DOTLINE,COLORGRAY;
  22. 50,DOTLINE,COLORGRAY;
  23. 100,DOTLINE,COLORGRAY;
  24. RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  25. RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
  26. 短期B:=SMA(RSV1,3,1);
  27. 短期A:=SMA(短期B,3,1);
  28. K4:=SMA(RSV4,8,1);
  29. 中期波段:SMA(K4,3,1),LINETHICK0,COLORWHITE;
  30. VV1:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
  31. VV2:=SMA(VV1,3,1);
  32. VV3:=3*VV1-2*VV2;
  33. 趋势:=EMA(VV3,3);
  34. VV4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
  35. 准备资金:IF(趋势<13,1,0),LINETHICK0,COLORCYAN;
  36. 开始建仓:IF(趋势<13 AND VV4>13,1,0),LINETHICK0,COLORYELLOW;
  37. VA1:=(CLOSE*2+HIGH+LOW)/4*10;
  38. VA2:=EMA(VA1,13);
  39. VA3:=EMA(VA1,34);

  40. VA4:=VA2-VA3;
  41. VA5:=EMA(VA4,5);
  42. VA6:=2*(VA4-VA5)*5.5;
  43. 主力进场:IF(VA6>=0 AND 趋势<13,1,0),LINETHICK0,COLORFF00FF;
  44. 转折:=IF(REF(中期波段,1)<REF(中期波段,2) AND 中期波段>REF(中期波段,1),1,0);
  45. 先机共振抄底:IF(开始建仓=1 AND 主力进场=1 AND 中期波段>REF(中期波段,1),1,0),COLORRED,LINETHICK0;
  46. 短线波段:IF((转折=1 AND 短期B>=短期A) OR (REF(短期B,1)<REF(短期A,1) AND 短期B>=短期A AND 中期波段>REF(中期波段,1)),1,0),LINETHICK0,COLOR0080EF;
  47. STICKLINE(短期B>=短期A,短期A,REF(短期A,1),3,0),COLOR0080EF;
  48. STICKLINE(短期B<短期A,短期A,REF(短期A,1),3,0),COLORFF6600;
  49. DRAWICON(先机共振抄底=1,REF(短期A,1),1);
  50. DRAWICON(短线波段=1 AND 先机共振抄底=0,REF(短期A,1),7);
  51. SMA(K4,3,1),COLORGREEN,LINETHICK3; IF(中期波段>REF(中期波段,1),中期波段,DRAWNULL),LINETHICK3,COLORRED;
  52. STICKLINE(准备资金=1,3,-2,5,0),COLORCYAN;
  53. STICKLINE(开始建仓=1,10,-2,5,0),COLORYELLOW;
  54. STICKLINE(主力进场=1 AND 开始建仓=1,6,-2,5,0),COLORFF00FF;
  55. 资金流入强度:ZJLRQD,LINETHICK2,COLORRED;
  56. 市场筹码总量:INTPART(ZCMZL),COLORWHITE,NODRAW;
复制代码

三线共振副图指标

三线共振副图指标

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1