开启左侧

通达信智能macd副图指标 源码 无加密

[复制链接]
macd 指标的改进,信号比传统的早一点
  1. {DRAWGBK(C>0, RGB(0,108,108),RGB(88,0,0),0,'11',0);}
  2. SHORT:=12;LONG:=26;MID:=9;
  3. DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
  4. DEA:EMA(DIF,MID);
  5. MACD:(DIF-DEA)*2,COLORSTICK;

  6. DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,DIF*1.1,1),COLORRED;

  7. HJ_2:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
  8. HJ_3:=LLVBARS(MACD,HJ_2+20);
  9. HJ_4:=IF(HJ_3>HJ_2,REF(MACD,HJ_3),0);
  10. HJ_5:=MACD<0 AND MACD>HJ_4 AND LOW=LLV(LOW,HJ_2+20) AND HJ_4<0;
  11. HJ_6:=REF(HJ_5,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_3)<0 AND MACD<0;

  12. 底背:DRAWLINE(HJ_4=HJ_3,MACD,HJ_6,MACD,0),COLORRED,DOTLINE;
  13. DRAWICON(HJ_6,MACD*1.2,9);

  14. HJ_7:=HHVBARS(MACD,HJ_2+20);
  15. HJ_8:=IF(HJ_7>HJ_2,REF(MACD,HJ_7),0);
  16. HJ_9:=MACD>0 AND MACD<HJ_8 AND HIGH=HHV(HIGH,HJ_2+20) AND HJ_8>0;
  17. HJ_10:=REF(HJ_9,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_7)>0;

  18. 顶背:DRAWLINE(HJ_8=HJ_7,MACD,HJ_10,MACD,0),COLOR1D7300,DOTLINE;
  19. DRAWICON(HJ_10,MACD*1.2,15);

  20. HJ_11:=CLOSE/MA(CLOSE,40)*100<78;
  21. HJ_12:=CLOSE/MA(CLOSE,60)*100<74;
  22. HJ_13:=HIGH>LOW*1.051;
  23. HJ_14:=HJ_13 AND COUNT(HJ_13,5)>1;
  24. HJ_15:=IF(HJ_14 AND (HJ_11 OR HJ_12),2,0);
  25. HJ_16:=CLOSE/REF(CLOSE,25)<=1.1;
  26. HJ_17:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
  27. HJ_18:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
  28. HJ_19:=SMA(HJ_18,2,1);
  29. HJ_20:=SMA(HJ_19,2,1);
  30. HJ_21:=IF(HJ_19>REF(HJ_19,1) AND REF(HJ_19,1)<REF(HJ_19,2) AND HJ_19<23,1.5,0);


  31. HJ_22:=100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8));
  32. HJ_23:=MA(CLOSE,5);
  33. HJ_24:=IF(CLOSE>SAR(10,2,20),1,0);
  34. HJ_25:=IF(CLOSE<SAR(10,2,20),(-1),0);
  35. HJ_26:=ATAN((HJ_23/REF(HJ_23,1)-1)*100)*180/3.1416;
  36. HJ_27:=IF(HJ_26>30,1,0);
  37. HJ_28:=IF(HJ_26<(-30),(-1),0);
  38. HJ_29:=HJ_24+HJ_27+HJ_25+HJ_28;
  39. IF(HJ_29<(-1) OR HJ_22<25.01,DIF,DRAWNULL),COLOR1D7300;
  40. IF(HJ_22>74.989998 OR HJ_29>0,DIF,DRAWNULL),COLORRED;


  41. 0,COLORBROWN,POINTDOT;
复制代码

通达信智能macd副图指标 源码

通达信智能macd副图指标 源码

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1