开启左侧

股票财务信息主图指标 源码 通达信 无加密

[复制链接]
  1. MA(C,5);
  2. MA(C,10);
  3. MA(C,20);
  4. MA(C,30);

  5. {显示基本信息}
  6. DRAWTEXT_FIX(ISLASTBAR,0.8,0.05,1,STRCAT(STRCAT(HYBLOCK,' '), STRCAT(STRCAT(DYBLOCK,' '),GNBLOCK))),COLORGREEN;
  7. 总市值:FINANCE(41)/100000000,NODRAW;
  8. 流通市值:FINANCE(40)/100000000,NODRAW;
  9. 获利盘比例:WINNER(C),NODRAW;

  10. {左侧}
  11. {利润同比:=STRCAT('利润同比:',CON2STR(FINANCE(43),2));
  12. 收入同比:=STRCAT('收入同比:',CON2STR(FINANCE(44),2));
  13. 主营利润率:=STRCAT('主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
  14. 所属地域:=STRCAT('所属地域:',DYBLOCK);
  15. 所属行业:=STRCAT('所属行业:',HYBLOCK);
  16. 所属概念:=STRCAT('所属概念:',GNBLOCK);}

  17. 所属风格:=STRCAT('所属风格:',FGBLOCK);
  18. 主营业务:=STRCAT('主营业务:',EXTERNSTR(0,2));
  19. {DRAWTEXT_FIX(1,0.00,0.01,0,利润同比),COLORWHITE;
  20. DRAWTEXT_FIX(1,0.11,0.01,0,收入同比),COLORMAGENTA;
  21. DRAWTEXT_FIX(1,0.22,0.01,0,主营利润率),COLOR0080FF;
  22. DRAWTEXT_FIX(1,0.00,0.05,0,所属地域),COLORYELLOW;
  23. DRAWTEXT_FIX(1,0.00,0.09,0,所属行业),COLORYELLOW;
  24. DRAWTEXT_FIX(1,0.00,0.13,0,所属概念),COLORYELLOW;}

  25. DRAWTEXT_FIX(1,0.00,0.01,0,所属风格),COLORCYAN;
  26. DRAWTEXT_FIX(1,0.00,0.06,0,主营业务),COLORGREEN;

  27. {风险系数}
  28. X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
  29. X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}
  30. X3:=FINANCE(23)/FINANCE(10)*3.3;
  31. X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
  32. X5:=FINANCE(20)/FINANCE(15)*0.999;
  33. Z值:=X1+X2+X3+X4+X5;

  34. DRAWTEXT_FIX(1,0.85,0.01,1,'财务预警:'),COLORRED;
  35. DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,' ●重 警●'),COLORLIRED;
  36. DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,' ○轻 警○'),COLOR0099FF;
  37. DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,' ◎无 警◎'),COLORLIGREEN;

  38. {财务信息}
  39. 市盈率1:=DYNAINFO(39);
  40. {净资收益率:=(FINANCE(33)/FINANCE(34)*100);}
  41. 营业收入:=FINANCE(20)/10000;
  42. 销售毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);
  43. 净利润:=FINANCE(30)/10000;
  44. 净利润比率:=(FINANCE(30)/FINANCE(20)*100);
  45. 主营利润率1:=(FINANCE(23)/FINANCE(20)*100);
  46. 优质资产率:=((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19));{理论上越大越好但不同行业有不同标准};
  47. 现金负债比:=(FINANCE(25)/FINANCE(15));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
  48. 净利同增率:=FINANCE(43);

  49. DRAWTEXT_FIX(1,0.42,0.10,1,'市盈率:'),COLORYELLOW;
  50. DRAWTEXT_FIX(1,0.42,0.15,1,'收入 万元:'),COLORYELLOW;
  51. DRAWTEXT_FIX(1,0.42,0.20,1,'销售毛利率:'),COLORYELLOW;
  52. DRAWTEXT_FIX(1,0.42,0.25,1,'净利 万元:'),COLORYELLOW;
  53. DRAWTEXT_FIX(1,0.42,0.30,1,'净利润率 :'),COLORYELLOW;
  54. DRAWTEXT_FIX(1,0.42,0.35,1,'主营利润率:'),COLORYELLOW;
  55. DRAWTEXT_FIX(1,0.42,0.40,1,'优质资产率:'),COLORYELLOW;
  56. DRAWTEXT_FIX(1,0.42,0.45,1,'现金负债比:'),COLORYELLOW;
  57. {DRAWTEXT_FIX(1,0.42,0.75,1,'净利同增率:'),COLORYELLOW;}
  58. DRAWNUMBER_FIX(1,0.47,0.10,1,市盈率1),COLORWHITE;
  59. DRAWNUMBER_FIX(1,0.47,0.15,1,营业收入),COLORWHITE;
  60. DRAWNUMBER_FIX(1,0.47,0.20,1,销售毛利率),COLORWHITE;
  61. DRAWNUMBER_FIX(1,0.47,0.25,1,净利润),COLORWHITE;
  62. DRAWNUMBER_FIX(1,0.47,0.30,1,净利润比率),COLORWHITE;
  63. DRAWNUMBER_FIX(1,0.47,0.35,1,主营利润率1),COLORWHITE;
  64. DRAWNUMBER_FIX(1,0.47,0.40,1,优质资产率),COLORWHITE;
  65. DRAWNUMBER_FIX(1,0.47,0.45,1,现金负债比),COLORWHITE;
  66. {DRAWNUMBER_FIX(1,0.47,0.75,1,净利同增率),COLORWHITE;}
  67. {DRAWTEXT_FIX(1,0.498,0.01,1,'财务指标:'),COLORRED;}
  68. 市净率:=CONST(DYNAINFO(7) / FINANCE(34));
  69. {市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));}
  70. 营收同比增:=FINANCE(44);
  71. 每股净资产:=FINANCE(34);
  72. 每股收益季:=CONST(FINANCE(33)/(5-FINANCE(37)));
  73. {每股收益年:=CONST(FINANCE(33));}
  74. 每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
  75. 每股未分配:=CONST(FINANCE(32));
  76. 每股公积金:=CONST(FINANCE(18));

  77. DRAWTEXT_FIX(1,0.54,0.10,1,'市净率 :'),COLORYELLOW;
  78. DRAWTEXT_FIX(1,0.54,0.15,1,'收入同比增 :'),COLORYELLOW;
  79. DRAWTEXT_FIX(1,0.54,0.20,1,'每股净资产:'),COLORYELLOW;
  80. DRAWTEXT_FIX(1,0.54,0.25,1,'净利同比增:'),COLORYELLOW;
  81. DRAWTEXT_FIX(1,0.54,0.30,1,'每股收益季:'),COLORYELLOW;
  82. {DRAWTEXT_FIX(1,0.54,0.45,1,'每股收益年:'),COLORYELLOW;}
  83. DRAWTEXT_FIX(1,0.54,0.35,1,'每股现金流:'),COLORYELLOW;
  84. DRAWTEXT_FIX(1,0.54,0.40,1,'每股未分配:'),COLORYELLOW;
  85. DRAWTEXT_FIX(1,0.54,0.45,1,'每股公积金:'),COLORYELLOW;
  86. DRAWNUMBER_FIX(1,0.57,0.10,1,市净率),COLORWHITE;
  87. DRAWNUMBER_FIX(1,0.57,0.15,1,营收同比增),COLORWHITE;
  88. DRAWNUMBER_FIX(1,0.57,0.20,1,每股净资产),COLORWHITE;
  89. DRAWNUMBER_FIX(1,0.57,0.25,1,净利同增率),COLORWHITE;
  90. DRAWNUMBER_FIX(1,0.57,0.30,1,每股收益季),COLORWHITE;
  91. {DRAWNUMBER_FIX(1,0.57,0.45,1,每股收益年),COLORWHITE;}
  92. DRAWNUMBER_FIX(1,0.57,0.35,1,每股现金流),COLORWHITE;
  93. DRAWNUMBER_FIX(1,0.57,0.40,1,每股未分配),COLORWHITE;
  94. DRAWNUMBER_FIX(1,0.57,0.45,1,每股公积金),COLORWHITE;

  95. {DRAWTEXT_FIX(ISLASTBAR,0.8,0.05,1,STRCAT(STRCAT('流通盘: ',CON2STR(流通市值,2)),'亿 总市值:'), STRCAT(STRCAT(DYBLOCK,' '),GNBLOCK))),COLORGREEN;};
复制代码

股票财务信息主图指标 源码

股票财务信息主图指标 源码

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝0

帖子201

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1