开启左侧

经纬操盘线主图指标 源码 通达信

[复制链接]
  1. {短线英豪}
  2. 动力线:MA(C,5),LINETHICK3,COLOR00CCFF;
  3. 牛熊线:MA(C,13),CIRCLEDOT,COLORYELLOW;
  4. 生命线:MA(C,34),CIRCLEDOT,COLORMAGENTA;
  5. MA05:=MA(C,5);
  6. MA10:=MA(C,10);
  7. MA20:=MA(C,20);
  8. MA30:=MA(C,30);
  9. 五日乖离率:=(C-MA05)/MA05*100;
  10. BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
  11. 速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
  12. 加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
  13. IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
  14. BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
  15. IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
  16. 三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
  17. VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
  18. VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
  19. BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
  20. 强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
  21. 加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
  22. AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
  23. 清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
  24. DRAWTEXT(加仓 ,LOW*0.98,'◆加二'),COLORYELLOW;
  25. JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
  26. 减仓:=FILTER(JC,10);
  27. MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
  28. 买入:=FILTER(MR,10);
  29. DRAWTEXT(减仓,HIGH*1.02,'◆风险'),COLORCYAN;
  30. DRAWTEXT(买入,LOW*0.96,'◆买二'),COLORYELLOW;
  31. DRAWTEXT(清仓 ,HIGH*1.00,'◆清仓'),COLORGREEN;
  32. VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
  33. VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
  34. MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
  35. 压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
  36. 支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;
  37. {彩色K线}
  38. TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
  39. TYX4:=MA((C+L+O+H)/4,13);
  40. TYX5:=EMA((C+L+O+H)/4,21);
  41. {空心红}
  42. STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
  43. STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
  44. {深绿}
  45. STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
  46. STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
  47. STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
  48. STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
  49. {蓝}
  50. STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
  51. STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
  52. STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
  53. STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
  54. {黄}
  55. STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
  56. STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
  57. STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
  58. STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;

  59. {粉红}
  60. STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
  61. STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
  62. STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
  63. STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
  64. {亮灰}
  65. STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
  66. STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
  67. STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
  68. STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
  69. {深红}
  70. STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
  71. STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
  72. STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
  73. STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;

  74. {涨跌停K线}
  75. STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (CLOSE/REF(CLOSE,1))>1.048,HIGH,LOW,3,0) ,COLORRED;
  76. STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (REF(CLOSE,1)/CLOSE)>1.048,HIGH,LOW,3,0) ,COLOR00FF00;
  77. {突破}
  78. STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
  79. {买卖主图}
  80. MA18:=MA(CLOSE,18);
  81. MTM:=C-REF(C,1);
  82. DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
  83. 买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
  84. DRAWTEXT(FILTER(买=1,5),LOW,'★买一'),COLORRED;
  85. 加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
  86. DRAWTEXT(加1,LOW*0.99,'★加一'),COLORCC66FF;
  87. 卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
  88. DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★卖一'),COLORGREEN;
  89. {牛熊通吃}
  90. AA1:=AMOUNT/V;
  91. BB1:=L<AA1*0.9;
  92. CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
  93. DD1:=L<MA(C,5)*0.921;
  94. EE1:=V<MA(V,5)*1.5;
  95. FF1:=BB1 AND CC1 AND DD1 AND EE1;
  96. DRAWTEXT(FF1,LOW*0.99,'老鼠仓'),COLOR4080FF;
  97. {预测明天}
  98. XXS:=MA(LOW,5)*(1-5/100);
  99. XXS1:=MA(HIGH,5)*(1+5/100);
  100. 均线:=C,COLORGREEN;
  101. AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ;
  102. DRAWTEXT(AAAA,L*0.95,'下影买'),COLORRED;
  103. BBAA:=CROSS(XXS1,C);
  104. DRAWTEXT(CROSS(XXS1,C),H,'开盘逃'),COLORWHITE;
  105. DDDD:=CROSS(C,XXS1);
  106. DRAWTEXT(DDDD,H,'明日走'),COLORYELLOW;
  107. {兄弟指标}
  108. AAA:=MA(LOW,5)*(1-5/100);
  109. BBB:=(HHV(AAA,5)+LLV(AAA,5))/2;
  110. DRAWTEXT(CROSS(BBB,L) AND BBB>REF(BBB,1),L*0.98,'←兄弟回马枪'),COLORWHITE;
  111. {天河指标}
  112. DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
  113. DEA:=EMA(DIF,9);
  114. DRAWTEXT(REF(CROSS(DEA,DIF),1) AND CROSS(DIF,DEA),L*0.97,'←天河回马抢'),COLORMAGENTA;
  115. {见好就收}
  116. VSR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
  117. VSR3:=SMA(VSR2,4,1);
  118. VSR4:=SMA(VSR3,2,1);
  119. DRAWTEXT(VSR4>82 AND VSR3>89,HHV(C,30)*1.02,'收'),COLORGREEN;
复制代码

经纬操盘线主图指标

经纬操盘线主图指标

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝10

帖子2058

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1