开启左侧

KT交易师指标 罗威老师全套指标分享

[复制链接]
本帖最后由 ynjie 于 2020-2-13 13:13 编辑

​​工欲善其事,必先利其器
希望大家都能认真学习罗威老师的技术,每天认真看文章,成为罗威老师铁粉,报名参加罗威老师的课程,一起赚钱
这里发一套底色是白色的指标,喜欢底色是黑色的同学自己修改一下颜色就可以了。
主图指标
截图,注意图中画红框的位置。

罗威指标

罗威指标
代码(直接复制下面的代码,不要自己敲)
  1. MA20:MA(C,20),COLORGREEN,LINETHICK3;
  2. MA60:MA(C,60),COLORBLUE,LINETHICK3;
  3. CURRBARSCOUNT:=DATACOUNT-BARPOS;
  4. DRAWICON(CURRBARSCOUNT=20,H*1.02,13);
  5. DrawNumber(CURRBARSCOUNT=20,H*1.025,c,2),ColorGreen;
  6. DRAWICON(CURRBARSCOUNT=60,H*1.02,15);
  7. DrawNumber(CURRBARSCOUNT=60,H*1.025,c,2),ColorBlue;
  8. UB:MA(C,N)+(M/10)*STD(C,20),COLOR339900,LINETHICK2;
  9. LB:MA(C,N)-(M/10)*STD(C,20),COLOR2693FF,LINETHICK2;
  10. PartLine(MA20>REF(MA20,1),MA20),COLORRED,LINETHICK3;
  11. PartLine(MA60>REF(MA60,1),MA60),COLORMAGENTA,LINETHICK3;
复制代码

效果如下图
注释写到图上了,扣抵值大家看图上的注释吧。

罗威指标

罗威指标
主图BOLL20显示效果图
副图指标:
罗威KD指标

罗威指标

罗威指标
罗威KD指标代码
代码(直接复制下面的代码,不要自己敲):
  1. RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
  2. K:SMA(RSV,M1,1),ColorRed;
  3. D:SMA(K,M2,1),ColorBlue;
  4. J:3*K-2*D,NODRAW,COLORMAGENTA;
  5. FillRgn(K>D,D,K),ColorRed;
  6. DRAWICON(CROSS(K,D),K,4);
  7. DRAWICON(CROSS(D,K),D,5);
  8. 判:REF((D*3-K*2)*(HHV(H,(N-1))-LLV(L,(N-1)))/100+LLV(L,(N-1)),1),NODRAW,ColorRed;
  9. 预20:REF(LLV(L,(N-1))+(HHV(H,(N-1))-LLV(L,(N-1)))*(M1*20-(M1-1)*K)/100,1),NODRAW,ColorBlue;
  10. 预50:REF(LLV(L,(N-1))+(HHV(H,(N-1))-LLV(L,(N-1)))*(M1*50-(M1-1)*K)/100,1),NODRAW,ColorBlue;
  11. 预80:REF(LLV(L,(N-1))+(HHV(H,(N-1))-LLV(L,(N-1)))*(M1*80-(M1-1)*K)/100,1),NODRAW,ColorBlue;
  12. JC:="KD.D">"KD.K";
  13. SC:="KD.K">"KD.D";
  14. 金叉天数:BARSLAST(JC),NODRAW,ColorRed;
  15. 死叉天数:BARSLAST(SC),NODRAW,ColorBlue;
  16. DRAWICON(COUNT(K>80,1)=1,97,10);
  17. DRAWICON(COUNT(K<20,1)=1,3,11);
  18. DRAWICON(COUNT(K>80,3)=3,97,12);
  19. DRAWICON(COUNT(K<20,3)=3,3,12);
复制代码

效果如下图:
罗威KD指标效果图
图中,K值进入80会显示出红色圆点高档钝化红色圆点出现后的黄色圆点;K值进入20会显示绿色圆点低档钝化绿色圆点后的黄色圆点后面的数字代表当天如果股价到达此数字时,如果当前是死叉状态就会出现金叉,如果当前是金叉状态就会出现死叉预20,预50,预80后面的数字代表当天如果股价到达此数字,K值就会到达20,50,80金叉天数代表当前是金叉多少根k线了,死叉天数代表当前死叉多少根K线了。
乖离白色指标:

乖离白色指标

乖离白色指标
乖离指标代码
代码(直接复制下面的代码,不要自己敲):
  1. GL:MA(C,N)-MA(C,M),ColorRed;
  2. STICKLINE(GL>0,0,GL,5,0),ColorBrown;
  3. STICKLINE(GL>0 AND GL<REF(GL,1),0,GL,5,0),ColorMagenta;
  4. STICKLINE(GL<0,0,GL,5,0),COLORBLUE;
  5. STICKLINE(GL<0 AND GL>REF(GL,1),0,GL,5,0),ColorBlack;
复制代码

效果图如下

乖离指标效果图

乖离指标效果图
乖离指标效果图
多周期KD
日线——周线双周期,高档钝化的应用。

日线——周线 双周期,高档钝化显示

日线——周线 双周期,高档钝化显示
日线——周线 双周期,高档钝化显示
周线——月线双周期,高档钝化的应用

周线——月线双周期,高档钝化的显示

周线——月线双周期,高档钝化的显示
周线——月线双周期,高档钝化的显示
多周期KD同时在一个副图的指标,其实就是把KD指标扁平化处理了一下,看起来更直观

周线——月线双周期,高档钝化的显示

周线——月线双周期,高档钝化的显示
多周期KD
由于交易师目前还不支持季线的引用,多周期KD只做到了月线引用
下面贴一张通达信的,通达信支持季线引用多周期KD指标很完善
5fb9b411ly1fznsrh42rrj212w0jg43y.jpg
通达信多周期KD
指标说明:图中KD指标下面的5行分别是日,周,月,季,年五个周期的KD引用,颜色说明:空心黑色代表K小于D,有颜色的代表K大于D,黄色代表K值20之下,浅粉色20-50之间,红色50-80之间,深粉色80之上,高档钝化为白色细长空心矩形(贯穿正方形的空心矩形),低档钝化为黄色细长空心矩形。多和空后面的数字就是罗威老师的KD多空比,多空比用来仓位控制上下级对应关系是不是一目了然了。
回复
0

使用道具 举报

精彩评论1

BIXIUSHIWU 发表于 2020-5-18 10:45:30 | 显示全部楼层
怎么设置项里,有一个“步长”设置,没有啊。另外公式要出错。通不过。
回复

使用道具 举报

懒得打字嘛,点击快捷回复 【回复乱码 永久禁言】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝2

帖子1149

发布主题
推荐素材更多+
广告位


QQ- Archiver-手机版-小黑屋-经典-圈子- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1