开启左侧

5分钟KD 15分KD 30分KD 60分KD 日周月季年KD源码

[复制链接]
本帖最后由 ynjie 于 2020-2-13 12:53 编辑

好多人都在问怎么在日线显示周线的KD,月线KD,也就是多周期KD的显示问题。之前答应过大家的会免费分享出来,趁着过年这几天大家有空,大家设置出来多看图吧。
今天我们就来进行第一步的设置。第一步只是显示
文章要仔细看哦,有好多问题就藏在细节里,文字描述大家要仔细看,有好多问题都在描述里写过的
首先说明这次分享的只是显示出来kd的线条和交叉,最后的难点(这次不分享难点的代码)是正确的显示高档钝化以及低档钝化的小圆点,有朋友会问了,都显示出kd线条了,高低档的钝化还不好显示吗,这就涉及到引用周期和当前周期的问题了,我们先举个例子,比如我在日线引用周线kd,日线的5根K线才能显示一根周K线,这样问题就来了,当周KD站上80的第3天,日线图引用的周kd就显示高档钝化了,这样是不对的,应该在站上第三周才对,你在日线看到的高档钝化,在打开周线图看的时候才第一周站上80,高档钝化消失了,有罗威老师多周期KD实战分析这本书的,翻看一下177到179页,尤其是179页第一段的说明,有了这个概念,大家会一点代码改写的可以试试怎么才能正确显示高低档钝化,动动脑筋,当初这个问题困扰了我好久的(这次不分享高低档钝化,正确显示的问题我已经解决了),先把显示的代码分享给大家。大家安装好后,多看图,多动脑。
引用的时候注意事项必须认真看这里):第一,当前级别引用只能引用比当前级别大的周期引用。就是不能再日线图上引用60分钟;第二,当前级别引用上个级别的KD,在开盘状态下上个周期是变动的,要等上个周期收盘后为准,就是日线图引用周KD要等周五收盘周KD才不会再改变,盘中是会变动的。
先把指标创建好,
通达信,这个只能在电脑端使用,手机端不支持多周期的函数
新建指标,指标名字可以随意改成自己方便操作的名字,我这里写这么长是为了大家理解。
五分钟KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#MIN5"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#MIN5"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

十五分钟KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#MIN15"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#MIN15"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

三十分钟KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#MIN30"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#MIN30"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

六十分钟KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#MIN60"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#MIN60"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

日KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#DAY"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#DAY"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

周KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#WEEK"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#WEEK"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

月KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#MONTH"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#MONTH"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

季KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#SEASON"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#SEASON"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

年KD引用:
  1. STICKLINE(1,0,0,100,0),COLORRED;
  2. STICKLINE(1,20,20,100,0),COLORLIBLUE;
  3. STICKLINE(1,50,50,100,0),COLORBLUE;
  4. STICKLINE(1,80,80,100,0),COLORMAGENTA;
  5. STICKLINE(1,100,100,100,0),COLORGREEN;
  6. K:"KDJ.K#YEAR"(9,3,3),COLORRED,LINETHICK2;
  7. D:"KDJ.D#YEAR"(9,3,3),COLORBLUE,LINETHICK2;
  8. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  9. DRAWICON(CROSS(K,D),K,1);
  10. DRAWICON(CROSS(D,K),D,2);
复制代码

交易师代码:交易师不支持季KD的引用,所以那个季KD的指标就不要创建了
由于篇幅原因,这里就不一一贴代码了,就是把相应的通达信代码最后的三行
  1. DRAWBAND(K,RGB(250,0,0),D,RGB(0,250,0));
  2. DRAWICON(CROSS(K,D),K,1);
  3. DRAWICON(CROSS(D,K),D,2);
复制代码

替换为:
  1. FillRgn(K>D,D,K),colorred;
  2. FillRgn(K<D,K,D),colorgreen;
  3. DRAWICON(CROSS(K,D),K,4);
  4. DRAWICON(CROSS(D,K),D,5);
复制代码

怕大家操作有问题,这里举例一个周线的完整代码,大家对比一下就清楚了
周线KD引用:
  1. K:"KDJ.K#WEEK"(9,3,3);
  2. D:"KDJ.D#WEEK"(9,3,3);
  3. FillRgn(K>D,D,K),colorred;
  4. FillRgn(K<D,K,D),colorgreen;
  5. DRAWICON(CROSS(K,D),K,4);
  6. DRAWICON(CROSS(D,K),D,5);
复制代码

对比这个大家就可以把代码录入成功了。
准备工作做完了,下面我们把指标显示到界面上:
通达信,如果你想显示双周期的,就在主图上点右键指标窗口个数,三个窗口,或者用键盘直接按住alt键别放开,然后敲键盘的3,这样就是三个窗口的了,主图指标我们不用换,第一个副图指标我们用之前给大家的罗威KD钝化那个指标就可以了,第二个副图我们设置要看你当前的级别来修改,例如你现在看的是60分钟图,第二个图就要用日kd引用,如果你当前是日线图,那就要把第二个副图用周线KD引用。当然你也可以多周期显示,举个例子:比如设置5个副图的,按键盘alt+6,主图切换到60分钟的K线图,第一个副图不变还是罗威KD钝化,第二个副图用日线KD引用,第三副图用周KD引用,第四个副图用月KD引用,第五个图用季KD引用。这里只是例子,大家想要怎么显示都可以,要参照注意事项里的就可以了。
交易师的设置:菜单,画面,主副图数,选择自己想要显示的副图数量。
好了,这次就分享到这里,股市下周一就要开市了,大家准备工作做得怎么样了,罗威老师布置的作业都完成了吗?关于高档钝化低档钝化的显示问题,我会在今后的文章中慢慢给大家分享的,大家先看图理解指标。
快要结束了才想起来,还有多空比没分享出来,这里就分享一下通达信里面的多空比,因为交易师不支持季线引用,大家也可以在交易师中改编成只有日周月三级的多空比
通达信多空比
  1. VAR0001:="KDJ.K#DAY"(9,3,3);
  2. VAR0002:="KDJ.D#DAY"(9,3,3);
  3. VAR0004:="KDJ.K#WEEK"(9,3,3);
  4. VAR0005:="KDJ.D#WEEK"(9,3,3);
  5. VAR0006:="KDJ.K#MONTH"(9,3,3);
  6. VAR0007:="KDJ.D#MONTH"(9,3,3);
  7. VAR0008:="KDJ.K#SEASON"(9,3,3);
  8. VAR0009:="KDJ.D#SEASON"(9,3,3);多:IF(VAR0001>=VAR0002,1,0)+IF(VAR0004>=VAR0005,2,0)+IF(VAR0006>=VAR0007,3,0)+IF(VAR0008>=VAR0009,4,0),NODRAW,COLORRED;空:IF(VAR0001<VAR0002,-1,0)+IF(VAR0004<VAR0005,-2,0)+IF(VAR0006<VAR0007,-3,0)+IF(VAR0008<VAR0009,-4,0),NODRAW,COLORGREEN;
复制代码

这段代码加到之前的罗威kd钝化指标代码最后就可以了。

回复
0

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝1

帖子726

发布主题
推荐素材更多+
广告位

QQ- Archiver-手机版-小黑屋- 与你共享  

Powered by YNJIE.COM X3.3© 2001-2013 与你共享街.  滇ICP备19007624号-1